Miss call removes the sound icon in the notification bar

Bug #1555831 reported by taiebot65 on 2016-03-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
indicator-sound (Ubuntu)
High
Xavi Garcia
unity8 (Ubuntu)
High
Unassigned

Bug Description

phone: Mako
channel rc-proposed
15.04 r.258

When i get a miss call i can see that the sound icon has disappeared in the notification area. The way to get it back is triggering a volume change.

You can also notice the icon is disappearing when the notification is shown for the call if you do not take the call the icon will not show up until you mess around with a volume change. If you take the call the icon will come back.

Related branches

Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

Maybe has to do with the new playlist stuff, dbus log at the time has

virtual void AalMediaPlayerControl::pause()

TrackListReset signal received
Tracklist was cleared, resetting m_currentIndex to 0
virtual QMediaPlayer::MediaStatus AalMediaPlayerControl::mediaStatus() const

virtual QMediaPlayer::MediaStatus AalMediaPlayerControl::mediaStatus() const

virtual QMediaPlayer::MediaStatus AalMediaPlayerControl::mediaStatus() const

PlaybackStatus changed to: "stopped"
TrackListReset signal received
virtual bool QMediaPlaylist::setMediaObject(QMediaObject*)
void QMediaPlaylistPrivate::syncControls(QMediaPlaylistControl*, QMediaPlaylistControl*)
void AalMediaPlayerService::deletePlaylistControl()
virtual AalMediaPlaylistProvider::~AalMediaPlaylistProvider()
void AalMediaPlaylistProvider::disconnect_signals()
virtual AalMediaPlaylistControl::~AalMediaPlaylistControl()
void AalMediaPlayerService::deleteMediaPlayerControl()
void AalMediaPlayerService::destroyPlayerSession()
disconnected

Changed in indicator-sound (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
importance: Undecided → High
status: New → Confirmed
Charles Kerr (charlesk) wrote :

Pat, could you attach the output of this after the icon disappears?

dbus-send --print-reply --dest=com.canonical.indicator.sound "/com/canonical/indicator/sound" "org.gtk.Actions.DescribeAll"

Pat McGowan (pat-mcgowan) wrote :

There are no crash files, pusleaudio and the sound service keep running

Output attached
This is 100% reproducible, you need to wait for the ringtone to start playing then dismiss the call by sliding left

Pat McGowan (pat-mcgowan) wrote :

There are no crash files, pusleaudio and the sound service keep running

Output attached
This is 100% reproducible, you need to wait for the ringtone to start playing then dismiss the call by sliding left

Charles Kerr (charlesk) wrote :

from pat's dbus.txt log in comment 3.

> dict entry(
> string "visible"
> variant boolean true
> )

indicator-sound is still advertising itself as visible.

This doesn't appear to be an i-sound bug. Pat, could you assign someone on the unity8 side to take a look?

Changed in unity8 (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in canonical-devices-system-image:
assignee: Alejandro J. Cura (alecu) → Michał Sawicz (saviq)
Changed in indicator-sound (Ubuntu):
status: Confirmed → Incomplete
Changed in canonical-devices-system-image:
milestone: none → ww08-2016
Changed in indicator-sound (Ubuntu):
assignee: Charles Kerr (charlesk) → Xavi Garcia (xavi-garcia-mena)
Xavi Garcia (xavi-garcia-mena) wrote :

I managed to recreate, in fact it happens everytime.

I think it is an indicator-sound issue, as I can see the following difference in the indicator before and after the call:

BEFORE:
dict entry(
                        string "icon"
                        variant struct {
                              string "themed"
                              variant array [
                                    string "audio-volume-high-panel"
                                    string "audio-volume-high"
                                    string "audio-volume"
                                    string "audio"
                                 ]
                           }
                     )

AFTER:
dict entry(
                        string "icon"
                        variant struct {
                              string "themed"
                              variant array [
                                    string ""
                                 ]
                           }
                     )

The themed icon looks incorrect.

Investigating it...

Changed in indicator-sound (Ubuntu):
status: Incomplete → Confirmed
Charles Kerr (charlesk) wrote :

Oog. I stand corrected. Nice catch Xavi :)

Looks like this could be triggered in fallthrough ``default: return "";'' in get_volume_root_icon(), probably after VolumeControlPulse.calculate_active_output()'s returned VolumeControl.ActiveOutput.CALL_MODE.

Changed in unity8 (Ubuntu):
status: Confirmed → Invalid
Changed in indicator-sound (Ubuntu):
status: Confirmed → In Progress
Michał Sawicz (saviq) on 2016-03-18
Changed in canonical-devices-system-image:
assignee: Michał Sawicz (saviq) → Alejandro J. Cura (alecu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package indicator-sound - 12.10.2+16.04.20160317.1-0ubuntu1

---------------
indicator-sound (12.10.2+16.04.20160317.1-0ubuntu1) xenial; urgency=medium

  [ Xavi Garcia Mena ]
  * Changed to code to get the root icon. Now it does not take into
    account the source output, as in fact that code was not
    differentiating between any particular case. The code was added in
    the past in the case that we should differentiate between bluetooth,
    headphones, etc... but it was never used. (LP: #1555831)

 -- Xavi Garcia <email address hidden> Thu, 17 Mar 2016 10:06:26 +0000

Changed in indicator-sound (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments