ubuntu-touch vivid rootfs fails to build: cp: cannot stat 'chroot/usr/share/android/product/*-preinstalled-system-armel+manta.img': No such file or directory

Bug #1553069 reported by Jean-Baptiste Lallement on 2016-03-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Unassigned
livecd-rootfs (Ubuntu)
Critical
Łukasz Zemczak
livecd-rootfs (Ubuntu RTM)
Critical
Łukasz Zemczak

Bug Description

20160304 ubuntu-touch rootfs fails to build [1] with:

Setting up android (20160107-1211-0ubuntu5) ...
'chroot/usr/share/android/product/ubuntu-preinstalled-system-armel+flo.img' -> 'livecd.ubuntu-touch.system-armel+flo.img'
'chroot/usr/share/android/product/ubuntu-preinstalled-recovery-armel+flo.img' -> 'livecd.ubuntu-touch.recovery-armel+flo.img'
'chroot/usr/share/android/product/ubuntu-preinstalled-boot-armhf+flo.img' -> 'livecd.ubuntu-touch.boot-armhf+flo.img'
'livecd.ubuntu-touch.boot-armhf+flo.img' -> 'livecd.ubuntu-touch.bootimg-flo'
cp: cannot stat 'chroot/usr/share/android/product/*-preinstalled-touch-armel+flo.zip': No such file or directory
cp: cannot stat 'chroot/usr/share/android/product/*-preinstalled-system-armel+manta.img': No such file or directory

Probably because manta has been removed from the list of target still present somewhere in the livefs scripts.

[1] https://launchpadlibrarian.net/245614343/buildlog_ubuntu_vivid_armhf_ubuntu-touch_BUILDING.txt.gz

Changed in livecd-rootfs (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in canonical-devices-system-image:
importance: Undecided → Critical
status: New → Triaged
Changed in livecd-rootfs (Ubuntu):
status: New → Confirmed
Changed in livecd-rootfs (Ubuntu):
status: Confirmed → In Progress
Changed in livecd-rootfs (Ubuntu RTM):
importance: Undecided → Critical
status: New → In Progress
assignee: nobody → Łukasz Zemczak (sil2100)
Oliver Grawert (ogra) wrote :

flo is fine here (the message is bogus, all *.zip cp lines are shielded by an "|| true" so they will produce a message but not stop the execution ... )
this is plainly manta not providing a device img file from the android package build anymore.

Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package livecd-rootfs 2.300.2+vivid13 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

livecd-rootfs (2.300.2+vivid13) vivid; urgency=medium

  * Remove the manta device from the list of touchsubarches as we're not
    building its kernel anymore (LP: #1553069).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Fri, 04 Mar 2016 09:57:05 +0100

summary: ubuntu-touch vivid rootfs fails to build: cp: cannot stat
- 'chroot/usr/share/android/product/*-preinstalled-touch-armel+flo.zip':
- No such file or directory
+ 'chroot/usr/share/android/product/*-preinstalled-system-
+ armel+manta.img': No such file or directory
Changed in livecd-rootfs (Ubuntu RTM):
status: In Progress → Fix Released
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.382

---------------
livecd-rootfs (2.382) xenial; urgency=medium

  * Remove the manta device from the list of touchsubarches as we're not
    building its kernel anymore (LP: #1553069).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Fri, 04 Mar 2016 09:47:31 +0100

Changed in livecd-rootfs (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers