My Music scope no longer shows "get started!"

Bug #1539068 reported by Marcus Tomlinson on 2016-01-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Alejandro J. Cura
unity-scope-mediascanner (Ubuntu)
Critical
Marcus Tomlinson

Bug Description

The My Music scope no longer shows the "get started!" splash screen. The "My Videos" scope still seems to work though.

Related branches

Changed in unity-scope-mediascanner (Ubuntu):
status: New → Confirmed
Paweł Stołowski (stolowski) wrote :

Looks like category renderer definition broke:

[2016-01-28 12:38:26.986081] ERROR: mediascanner-music: QueryBase::run(): unity::InvalidArgumentException: CategoryRenderer(): invalid JSON definition:
    unity::ResourceException: Failed to parse json string: * Line 16, Column 5
  Missing '}' or object member name

Changed in unity-scope-mediascanner (Ubuntu):
assignee: nobody → Marcus Tomlinson (marcustomlinson)
status: Confirmed → In Progress
Changed in unity-scope-mediascanner (Ubuntu):
importance: Undecided → Critical
tags: added: regression-release
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → Critical
milestone: none → ww04-2016
status: New → In Progress
James Henstridge (jamesh) wrote :

While testing this out, I noticed that we don't display anything for local music in the music aggregator scope when there is no music. Without anything there, how is a user going to see this concierge card?

Currently the My Videos scope presents a link to the camera app in this case when aggregated. I'm not sure what would be appropriate for this scope, given that we don't have any apps to create music on the device.

Michi Henning (michihenning) wrote :

It would be nice touch to have something similar to videos here.

It raises an interesting question though: How is a user going to get their music collection onto the device if there is no slot for a flash card? adb push seems a little extreme for the average non-technical user…

Let's not have this stop the release though. Whether to show something or not here is a separate issue. I'll open a separate bug for this.

Paweł Stołowski (stolowski) wrote :

Yeah, as discussed on standup, this was specifically designed that way by Design team. The rationale was as you suspected - there is no way for user to "create" music, so there is no sensible action we could link the card to (we could surely show a dummy card which doesn't accept user input - similar to the card we have in My Music/My Videos where there no media files are present).
So the only way to see concierge for music is to go to My Music via Manage Dash.

Pat McGowan (pat-mcgowan) wrote :

The user would connect via MTP on a USB cable and drag the files in. We could possibly add such a description
Also the USB port itself nicely supports thumb drives with the mini plug.

Michi Henning (michihenning) wrote :

Right. But, on Macs, MTP isn't supported out of the box, so Mac users will have to install additional software: https://www.android.com/filetransfer/

We could use the concierge card for the music scope to mention this?

Michi Henning (michihenning) wrote :

So, I just tried this. The software fails to establish the USB connection. Marcus, does it work for you on OS X?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-mediascanner - 0.2+16.04.20160128-0ubuntu1

---------------
unity-scope-mediascanner (0.2+16.04.20160128-0ubuntu1) xenial; urgency=medium

  [ Michi Henning ]
  * Try to retrieve artist image even if all songs for an artist have an empty album tag (LP:1378278).
  * Fixed ambiguous string: "%s Features" -> "Featured on %s". (LP:
    #1351696)

  [ CI Train Bot ]
  * Resync trunk. added: po/eo.po

  [ James Henstridge ]
  * Limit the number of results returns for the genres departments, and
    for albums/songs of artists results.

  [ Marcus Tomlinson ]
  * Fix My Music "concierge" card and render 3 results in the "My Music"
    category of the Music aggregator (as per design) (LP: #1539068,
    #1539070)

 -- James Henstridge <email address hidden> Thu, 28 Jan 2016 14:14:58 +0000

Changed in unity-scope-mediascanner (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed

@Michi, to answer your earlier question: Yes AFT does work for me on Mac. Although, I did need to unplug and plug the device in about 3 times for it to recognise it.

Michi Henning (michihenning) wrote :

USB seems to be really flaky. I’ve just sent a question to the phablet list about this. Thanks for confirming!

The weird thing is that I can’t get it to work at all, even with my one known good cable. It always says that it failed to connect :(

It would be good to get reports from other people as to how well MTP works for them on a Mac. If i'm not the only one with this problem, we might have to come up with something better.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers