Viewfinder frozen and all buttons disabled after taking HDR picture

Bug #1537774 reported by Florian Boucault on 2016-01-25
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Bill Filler
camera-app (Ubuntu)
High
Florian Boucault

Bug Description

Reported by royden in https://bugs.launchpad.net/ubuntu/+source/camera-app/+bug/1475895/comments/6

"Testing the fix released for Bug #1519766 (and likely #1478693) I can reliably freeze the camera-app (v. 3.0.0.616) on rc-proposed Arale r227 by taking HDR images.

Freeze happens around the 3rd or 4th shot of the same subject as reported in Bug #1519766.

HDR shots of shaded lamp in semi-dark room (taking up 3/4 of view) trigger freeze on 4/5th shot.

HDR shots of lamp on small table at distance in semi-dark room do not reliably trigger freeze.

Normal shots do not trigger freeze, with or without zoom AFAIKS.

Freeze comprises either the viewfinder holding the image of the attempted capture and app being no longer responsive and needing to be closed. Re-opening produces "Cannot access camera" error message screen, with access permission or some other error as cause. Reboot needed to regain camera function.

Other freeze seen was a return of the viewfinder to a dark screen, and the same error message screen appearing."

Florian Boucault (fboucault) wrote :

Comments from royden:
"
https://bugs.launchpad.net/ubuntu/+source/camera-app/+bug/1519766/comments/6

The above comment by jibel seems to include the sort of hang I refer to here, in his case after 3 shots.

Attached is a sub-set of syslog across a series of photos that failed on the 4th one.

https://launchpadlibrarian.net/234932365/syslog_snippet_Camera-app.txt
https://launchpadlibrarian.net/234932421/application-click-com.ubuntu.camera_camera_3.0.0.616.log
"

Changed in camera-app (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Florian Boucault (fboucault)
Changed in canonical-devices-system-image:
status: New → Confirmed
Florian Boucault (fboucault) wrote :

Steps to reproduce:
1. Reboot device and launch camera app
2. Turn on HDR
3. On your laptop, display this jpeg full screen: https://launchpadlibrarian.net/227581954/image20151125_104448475.jpg
4. Take photos of your laptop display repeatedly (up to 20 times)

After taking of the photos the camera will freeze as described above.

Florian Boucault (fboucault) wrote :

Here are the relevant syslogs in normal and broken cases when taking HDR photos:

Normal case: http://pastebin.ubuntu.com/14663397/
Broken case: http://pastebin.ubuntu.com/14663459/

Most relevant difference:
[mt-i2c]ERROR,454: id=0,addr: 50, transfer error
[mt-i2c]ERROR,460: I2C_ACKERR
[mt-i2c]ERROR,454: id=0,addr: 37, transfer error
[mt-i2c]ERROR,460: I2C_ACKERR

Florian Boucault (fboucault) wrote :

Stressing the BQ E4.5 with the same scenario does not trigger this bug in any way. This looks more and more like a Meizu MX4 specific issue.

Florian Boucault (fboucault) wrote :

Reproduceable with rc-proposed image 180 from november.

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → backlog
Florian Boucault (fboucault) wrote :

Reproducible with stable image 1 from june: ubuntu-device-flash --revision=1 touch --device=arale --channel=ubuntu-touch/stable/meizu.en

Changed in canonical-devices-system-image:
milestone: backlog → ww08-2016
importance: High → Critical
Bill Filler (bfiller) on 2016-03-15
Changed in canonical-devices-system-image:
milestone: ww08-2016 → backlog
zubozrout (zubozrout) wrote :

I am having this or similar issue on my MX4 ever since HDR was present in the camera app. After 1 to n photos taken in HDR mode the camera freezes, doesn't save the taken HDR picture, doesn't even show it ... stays in a black screen with just a loading animation. In addition after closing the app and starting it again the camera app has no access to the camera and the device has to be rebooted in order to take additional images.

I also have this bug on MX4 with OTA13. However, I must notice that I2C_ACKERR errors also present in "good" case for me during the taking of photo. The difference between good and bad cases are that these errors appear in large quantity after the photo is taken.

I also would like to point out copious errors "inv_mpu: error in header parsing=8d00" (which could be seen in the original syslog for this bug), which also happen for me. They appear as a nearly endless spam in log when I try to focus camera on something, it seems.

Jay Bowles (penguinclaw-i) wrote :

I also have this issue with my Meizu mx4. I have found a hard reboot is the only thing that gets my phone is able again. I find this happens when I have the camera set at the highest resolution although I haven't tried it at lower res. Doesn't seem to be an issue with the selfish camera.

Same problem here, and also MX4.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers