Fix the user login experience on the greeter on a tablet

Bug #1536714 reported by Pat McGowan on 2016-01-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Michał Sawicz
livecd-rootfs (Ubuntu)
Undecided
Unassigned
livecd-rootfs (Ubuntu RTM)
Undecided
Unassigned
unity8 (Ubuntu)
Critical
Michael Terry
unity8 (Ubuntu RTM)
Undecided
Michael Terry

Bug Description

The current UX for tablets or when converged with a mouse attached is a bit of a placeholder showing the default phablet user.

We need to support two modes of the greeter that scales according to the available input devices. The first one is one that works across mobile and tablet devices in non-mouse connected / touch-centric state. Unlocking with no mouse connected would be exactly as it is today on the phone, which displays the Infographic until you touch the screen, and then you get a message that says "swipe to unlock" If you don't have a pin code set, the screen unlocks. if you have a pincode set, the touch pincode-entry pad appears.

If a mouse is connected, however, you get the more "desktop-friendly" greeter with the infographic, user-name and password entry field (just like what we have today) on tablet. If the user taps or clicks into the password edit box, the OSK is popped up (unless an external keyboard is also attached). If no password or pincode has been set, then instead of the password entry field, you would instead have a "login" button that clears the greeter.

On a tablet with mouse connected and no pincode set, the user could either swipe away the greeter or tap on the login button. If the user has a password/pincode set and attempts to swipe away the greeter, we should put up a hint message asking the user to enter their password/pincode to continue.

This incremental enhancement to recognize the mouse is more consistent with convergence because tablets are mobile devices, and if no mouse is attached, we should follow a touch-centric approach. In a mouse-connected state, we can assume the user will be favoring that device.

===============

Immediate problem: "phablet" name on the greeter login list. A bigger refactoring of the greeter for bigger screens will follow.

Related branches

Changed in canonical-devices-system-image:
milestone: none → ww04-2016
description: updated
Lukáš Tinkl (lukas-kde) wrote :

With the new OOBE wizard, we will gain a field for entering user's real name, so we could display that instead of the generic "phablet" logname, if the user had filled it.

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) wrote :

The immediate change we want is to display the "real name" instead of the user name in the greeter. The code does try to display "realName", but it always returns username only. So it looks like liblightdm-qt is doing it wrong.

On top of that, the phablet user on our touch images has GECOS set to "phablet", we should set it to "Ubuntu" and new OOBE will actually let users decide on first boot.

Changed in unity8 (Ubuntu):
status: Confirmed → Incomplete
Michał Sawicz (saviq) wrote :

I've printed out all the roles of my user:

qml: UsersModel.display: michal
qml: UsersModel.decoration: QVariant(QIcon)
qml: UsersModel.name: michal
qml: UsersModel.realName: michal
qml: UsersModel.loggedIn: false
qml: UsersModel.background: QVariant(QPixmap)
qml: UsersModel.backgroundPath:
qml: UsersModel.session:
qml: UsersModel.hasMessages: false
qml: UsersModel.imagePath:

So it's confirmed, all of display, name and realName roles return the same value.

Changed in lightdm (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
assignee: nobody → Michael Terry (mterry)
Changed in unity8 (Ubuntu):
status: Incomplete → Invalid
description: updated
Michael Terry (mterry) wrote :

Pat, we've been working with design (Patricia) to get actual design documents for the tablet greeter. Up until now, their guidelines have been "just copy what the desktop does" because they didn't have cycles for tablet stuff. Now, obviously, tablet and convergence matters more and they are working on visual specs as we speak.

But they haven't finished yet. And I'm loathe to make a redesign in advance of that.

But the issue with real names makes immediate sense. We'll need to (1) update the script that creates the phablet user to set Ubuntu, (2) fix liblighdmqt to return the actual real name, and (3) probably add a hack in unity8 to display "Ubuntu" for a system with a single "phablet" user for the upgrade case.

I'll start on it.

Michael Terry (mterry) wrote :

This turned out to be an issue in unity8, not lightdm. Resetting tasks.

Michał Sawicz (saviq) on 2016-02-01
Changed in unity8 (Ubuntu):
status: Invalid → In Progress
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) on 2016-02-01
Changed in unity8 (Ubuntu):
importance: Undecided → Critical
status: In Progress → Triaged
Michał Sawicz (saviq) on 2016-02-01
no longer affects: lightdm (Ubuntu)
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
tags: added: lt-blocker
Changed in unity8 (Ubuntu RTM):
assignee: nobody → Michael Terry (mterry)
status: New → In Progress
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package livecd-rootfs 2.300.2+vivid12 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

livecd-rootfs (2.300.2+vivid12) vivid; urgency=medium

  * live-build/ubuntu-touch/hooks/01-setup_user.chroot:
    - Change real name for phablet user to "Ubuntu" (LP: #1536714).

 -- Łukasz 'sil2100' Zemczak <email address hidden> Thu, 04 Feb 2016 17:46:00 +0100

Changed in livecd-rootfs (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Łukasz Zemczak (sil2100) wrote :
Download full text (16.2 KiB)

This bug was fixed in the package unity8 8.11+15.04.20160208-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

unity8 (8.11+15.04.20160208-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * LVWPH: Reset to initial values when list is empty (LP: #1540490)
  * Make LazyImage qmltest less flaky on CI

  [ Andrea Cimitan ]
  * Make LazyImage qmltest less flaky on CI

  [ CI Train Bot ]
  * Resync trunk.
  * Update translation template

  [ Michael Terry ]
  * Display the current user's real name on the tablet lockscreen. (LP:
    #1536714)

unity8 (8.11+16.04.20160129-0ubuntu1) xenial; urgency=medium

  [ Albert Astals Cid ]
  * Audio Preview Button: Don't gain focus on press (LP: #1517830)
  * Better attempt at sanitization
  * Better looking application scopes for wide screens
  * Call printSettings correctly
  * Card test: Limit the precision we ask for doubles to be equal
  * Convert while into tryCompareFunction
  * Do not use the same filepath parameter for all the card creator
    createQmlObject calls (LP: #1536379)
  * Fix some test shells being unstable in the armhf builders
  * Make revealByEdgePush more stable
  * More reliable compares
  * Move the mouse over the bfb before waiting for rendering
  * Remove the DDAs constrains for every test
  * Set the background source size to the max we'll need + new
    background (LP: #1539011)

  [ Andrea Cimitan ]
  * Dynamically change click scope card size according to size (LP:
    #1536745)
  * Should fix lazyimage test failures on fast machines

  [ CI Train Bot ]
  * Fix card tests on the phone
  * Update translation template

  [ Daniel d'Andrada ]
  * Desktop stage rotates only to follow screen orientation (LP:
    #1515977)

  [ Lukáš Tinkl ]
  * Hide/reveal the mouse pointer on touch/mouse events renamed:
    plugins/Utils/HomeKeyWatcher.cpp =>
    plugins/Utils/WindowInputMonitor.cpp plugins/Utils/HomeKeyWatcher.h
    => plugins/Utils/WindowInputMonitor.h
    tests/mocks/Utils/HomeKeyWatcher.qml =>
    tests/mocks/Utils/WindowInputMonitor.qml
    tests/plugins/Utils/HomeKeyWatcherTest.cpp =>
    tests/plugins/Utils/WindowInputMonitorTest.cpp

  [ Michael Terry ]
  * Synchronize the mouse-cursor-speed and touchpad-cursor-speed
    properties with USC. (LP: #1536383)

  [ Michael Zanetti ]
  * Add InputMethod to secondary screen
  * Add a virtual Touchpad while external screen is connected
  * Make big tablets switch to windowed mode by plugging a kbd only (LP:
    #1535399)
  * Prevent alt key presses from being dispatched to the app on alt+tab
    (LP: #1532862)

  [ Michał Sawicz ]
  * Make qmluitests.sh more robust and allow parallel test execution
  * Skip SessionBackendTest::testLogin1Capabilities until we talk to a
    mock instead (LP: #1532112, #1532113)

unity8 (8.11+16.04.20160122-0ubuntu1) xenial; urgency=medium

  [ Albert Astals Cid ]
  * Fix bug #1536296 added: tests/plugins/Dash/cardcreator/10.tst (LP:
    #1536296)
  * Fix card tests on the phone

  [ CI Train Bot ]
  * Update translation template

unity8 (8.11+16.04.20160111.1-0ubuntu1) xenial; urgency=medium

  [ Albert Astals Cid ]
  * Clear fak...

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Michał Sawicz (saviq) on 2016-02-09
Changed in avila:
status: New → Fix Committed
Pat McGowan (pat-mcgowan) wrote :

re-opening for the next update since the real work not done yet and there is lots of description captured here along with an MR

summary: - Fix the user login experience on the greeter
+ Fix the user login experience on the greeter on a tablet
Changed in canonical-devices-system-image:
milestone: ww04-2016 → ww08-2016
status: Fix Committed → In Progress
Changed in unity8 (Ubuntu RTM):
status: Fix Released → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.11+16.04.20160208-0ubuntu1

---------------
unity8 (8.11+16.04.20160208-0ubuntu1) xenial; urgency=medium

  [ Albert Astals Cid ]
  * LVWPH: Reset to initial values when list is empty (LP: #1540490)
  * Make LazyImage qmltest less flaky on CI

  [ Andrea Cimitan ]
  * Make LazyImage qmltest less flaky on CI

  [ CI Train Bot ]
  * Resync trunk.
  * Update translation template

  [ Michael Terry ]
  * Display the current user's real name on the tablet lockscreen. (LP:
    #1536714)

 -- Michał Sawicz <email address hidden> Mon, 08 Feb 2016 09:38:00 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2016-02-10
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in livecd-rootfs (Ubuntu):
status: New → Fix Released
Michał Sawicz (saviq) on 2016-02-10
no longer affects: ubuntu-ux
Michał Sawicz (saviq) wrote :

Will close this bug and track a bigger redesign elsewhere.

Changed in avila:
importance: Undecided → Critical
milestone: none → ww06-2016
Changed in avila:
milestone: ww06-2016 → none
no longer affects: avila
Łukasz Zemczak (sil2100) wrote :
Download full text (17.7 KiB)

This bug was fixed in the package unity8 8.11+15.04.20160212-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

unity8 (8.11+15.04.20160212-0ubuntu1) vivid; urgency=medium

  [ Albert Astals Cid ]
  * Do not use components in card creator generated code
  * Forward the makesurevisible signal from the inner preview widget
  * Make fallback also be fallback when the image is empty and not only
    on error (LP: #1531913)
  * Make the artShapeSize assignment be updated when using dynamic grid
    units
  * Visual improvements to the dash audio play cards
  * We don't use the unity-scope-scopes anymore (LP: #1439172)

  [ Andrea Cimitan ]
  * only request a bigger image if zoomable widget data property is
    true, otherwise just leave the screen size (LP: #1536814)

  [ CI Train Bot ]
  * Update translation template

  [ Daniel d'Andrada ]
  * Set initial surface size (LP: #1532974)

  [ Daniel d'Andrada, Michał Sawicz ]
  * Window Size Hints

  [ Florian Boucault ]
  * Splash screen: delay showing the ActivityIndicator by 2 seconds.

  [ Lukáš Tinkl ]
  * Replace the word "phone" with a more generic term "device" in the
    welcome wizard (LP: #1294732, #1543527)

  [ Michael Terry ]
  * Have the tablet greeter set appropriate OSK hints if the user has a
    passcode instead of a passphrase. (LP: #1544173)

  [ Michael Zanetti ]
  * Don't eat mouse events in the edgebarrer

  [ Michał Sawicz ]
  * Bump unity-api dependencies

  [ Nick Dedekind ]
  * Added support for secondary indicator actions (LP: #1398888)
  * Remove zombie if they're not animated. (LP: #1534541)
  * Removed unused panel resources

  [ Ted Gould ]
  * Start the indicators after Unity8 starts instead of before

unity8 (8.11+16.04.20160208-0ubuntu1) xenial; urgency=medium

  [ Albert Astals Cid ]
  * LVWPH: Reset to initial values when list is empty (LP: #1540490)
  * Make LazyImage qmltest less flaky on CI

  [ Andrea Cimitan ]
  * Make LazyImage qmltest less flaky on CI

  [ CI Train Bot ]
  * Resync trunk.
  * Update translation template

  [ Michael Terry ]
  * Display the current user's real name on the tablet lockscreen. (LP:
    #1536714)

unity8 (8.11+16.04.20160129-0ubuntu1) xenial; urgency=medium

  [ Albert Astals Cid ]
  * Audio Preview Button: Don't gain focus on press (LP: #1517830)
  * Better attempt at sanitization
  * Better looking application scopes for wide screens
  * Call printSettings correctly
  * Card test: Limit the precision we ask for doubles to be equal
  * Convert while into tryCompareFunction
  * Do not use the same filepath parameter for all the card creator
    createQmlObject calls (LP: #1536379)
  * Fix some test shells being unstable in the armhf builders
  * Make revealByEdgePush more stable
  * More reliable compares
  * Move the mouse over the bfb before waiting for rendering
  * Remove the DDAs constrains for every test
  * Set the background source size to the max we'll need + new
    background (LP: #1539011)

  [ Andrea Cimitan ]
  * Dynamically change click scope card size according to size (LP:
    #1536745)
  * Should fix lazyimage test failures on fast machines

  [ CI T...

Changed in unity8 (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers