Not requesting desktop content when connected to monitor

Bug #1534682 reported by Bill Filler on 2016-01-15
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical Pocket Desktop
High
Michał Sawicz
Canonical System Image
High
Michał Sawicz
qtubuntu (Ubuntu)
High
Gerry Boland
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

The ua string is supposed to change based on screensize and other hueristics, but this is not happening. Getting mobile ua string always, even when connected to monitor via slimport

using this build:
(r112) ubuntu-device-flash touch --channel=ubuntu-touch/rc-proposed/ubuntu-pd

Not seeing any messages in the browser log when I plug/unplug the monitor

Related branches

Bill Filler (bfiller) on 2016-01-15
Changed in canonical-devices-system-image:
milestone: none → ww04-2016
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
Changed in webbrowser-app (Ubuntu):
importance: Undecided → High
Changed in canonical-pocket-desktop:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) on 2016-01-15
tags: added: convergence
Changed in canonical-devices-system-image:
status: New → Confirmed
Gerry Boland (gerboland) wrote :

Qt not being told the screen changed. Qtubuntu work

Changed in qtubuntu (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Gerry Boland (gerboland)
Kugi Eusebio (kugi-igi) wrote :

Isn't this the same as https://bugs.launchpad.net/bugs/1504084 ?
I see that it was fixed already but I assume it hasn't landed yet on vivid channels since the package mentioned was for Xenial.

Olivier Tilloy (osomon) wrote :

No, it’s a slightly different issue: bug #1504084 was an issue in the browser app, this bug is in qtubuntu.

Changed in webbrowser-app (Ubuntu):
status: New → Invalid
Bill Filler (bfiller) on 2016-01-21
Changed in canonical-pocket-desktop:
assignee: Bill Filler (bfiller) → Michał Sawicz (saviq)
Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → Michał Sawicz (saviq)
no longer affects: canonical-devices-system-image
Changed in canonical-devices-system-image:
assignee: nobody → Michał Sawicz (saviq)
importance: Undecided → High
milestone: none → ww08-2016
status: New → Confirmed
Michał Sawicz (saviq) on 2016-02-04
Changed in canonical-devices-system-image:
status: Confirmed → Triaged
Changed in canonical-devices-system-image:
milestone: ww08-2016 → ww04-2016
Changed in canonical-devices-system-image:
milestone: ww04-2016 → ww08-2016
Gerry Boland (gerboland) wrote :

I've attached the QtUbuntu branch which
1. correctly updates applications of the screen their window is on, so the Screen information is correct
2. has getters and notifiers for these properties: scale & form factor

This branch relies on a QtMir branch to function correctly. All in progress

Changed in qtubuntu (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-pocket-desktop:
status: New → In Progress
Changed in canonical-devices-system-image:
status: Triaged → In Progress
Michał Sawicz (saviq) on 2016-03-09
Changed in canonical-devices-system-image:
milestone: ww08-2016 → backlog
Olivier Tilloy (osomon) wrote :

Any update on this?

Gerry Boland (gerboland) wrote :

Yep, as of now, you can fetch the shell mode by using the QPlatformNativeInterface::windowProperty api to fetch a "formFactor" property which will return an enum (look in mir for the enum interpretation) indicating what mode the shell is in. Connect to windowPropertyChanged for signal on change.

This is an intermediary means of accessing this info, and it is clunky. The UITK needs to grow a proper API for this. Lemme know if you need a hand.

Changed in qtubuntu (Ubuntu):
status: In Progress → Fix Released
Olivier Tilloy (osomon) wrote :

@Gerry: I’m aware of that new API to get the "formFactor" value, but I was referring to the original issue of the window’s screen property not being updated, see the first comment (the browser relies on the size of the current screen to decide whether to advertise a desktop or a mobile UA string). Is that fixed?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers