ubuntu-touch vivid rootfs fails to build on i386 - qml-module-qtmultimedia-gles/i386 unsatisfiable Depends: libqt5multimedia5 (>= 5.4.1-1ubuntu20)

Bug #1531492 reported by Jean-Baptiste Lallement on 2016-01-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
John McAleely
qtmultimedia-opensource-src-gles (Ubuntu)
Undecided
Jim Hodapp

Bug Description

Image fails to build on i386 today
https://launchpad.net/~ubuntu-cdimage/+livefs/ubuntu/vivid/ubuntu-touch/
https://launchpad.net/~ubuntu-cdimage/+livefs/ubuntu/vivid/ubuntu-touch/+build/48004

From the build log
The following packages have unmet dependencies:
 ubuntu-touch : Depends: qml-module-qtmultimedia-gles but it is not going to be installed

This is likely due to the release of qtmultimedia-opensource-src-gles 5.4.1-1ubuntu19~overlay2 yesterday. proposed-migration identified the following unsatisfiable dependency on i386/amd64 (from: https://requests.ci-train.ubuntu.com/static/britney/vivid/landing-058/excuses.html)

qtmultimedia-opensource-src-gles (5.4.1-1ubuntu19~overlay1 to 5.4.1-1ubuntu19~overlay2)

    Maintainer: Ubuntu Developers
    13 days old
    qml-module-qtmultimedia-gles/amd64 unsatisfiable Depends: libqt5multimedia5 (>= 5.4.1-1ubuntu20)
    qml-module-qtmultimedia-gles/i386 unsatisfiable Depends: libqt5multimedia5 (>= 5.4.1-1ubuntu20)
    Not considered

which is confirmed by apt:
$ LANG=C apt-get install -o Debug::pkgProblemResolver=1 qml-module-qtmultimedia-gles
...
Broken qml-module-qtmultimedia-gles:i386 Depends on libqt5multimedia5 [ i386 ] < none -> 5.4.1-1ubuntu19~overlay2 > ( libs ) (>= 5.4.1-1ubuntu20)
Broken qml-module-qtmultimedia-gles:i386 Depends on libqt5multimediaquick-p5 [ i386 ] < none -> 5.4.1-1ubuntu19~overlay2 > ( libs ) (>= 5.3.0)
  Considering libqt5multimediaquick-p5:i386 0 as a solution to qml-module-qtmultimedia-gles:i386 9999
  Re-Instated libqt5multimediaquick-p5:i386
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 qml-module-qtmultimedia-gles : Depends: libqt5multimedia5 (>= 5.4.1-1ubuntu20) but 5.4.1-1ubuntu19~overlay2 is to be installed
E: Unable to correct problems, you have held broken packages.

Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → John McAleely (john.mcaleely)
milestone: none → ww02-2016
Changed in qtmultimedia-opensource-src-gles (Ubuntu):
assignee: nobody → Jim Hodapp (jhodapp)
summary: - ubuntu-touch vivid rootfs fails to build on i386
+ ubuntu-touch vivid rootfs fails to build on i386 - qml-module-
+ qtmultimedia-gles/i386 unsatisfiable Depends: libqt5multimedia5 (>=
+ 5.4.1-1ubuntu20)
Jean-Baptiste Lallement (jibel) wrote :

 qtmultimedia-opensource-src-gles (5.4.1-1ubuntu19~overlay2build1) vivid; urgency=medium
 .
   * No-change rebuild to refresh dependencies.

Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
Changed in qtmultimedia-opensource-src-gles (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers