Always shows the "hearing damage" warning

Bug #1526057 reported by Martin on 2015-12-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
indicator-sound (Ubuntu)
High
Xavi Garcia

Bug Description

Everytime a new Song start to play always shows the "hearing damage" warning pops up. That's really annoying and if you read, write or play something it interrupts you every time.
Is it possible that it only pops up when the first song playing (after the app starts) ?

<https://wiki.ubuntu.com/Sound#limits>: "Whenever you increase volume, for the first time in 20 hours, such that acoustic output would be more than 85 dBA, an 'Increase Volume' dialog should appear..."

Martin (martin-bertram) on 2015-12-14
tags: added: damge
Changed in music-app:
status: New → Invalid
Martin (martin-bertram) on 2016-01-05
tags: added: damage
removed: damge
Pat McGowan (pat-mcgowan) wrote :

It would seem that once the warning is dismissed and there are no further vol changes for that mode that it need not be shown.
A vol setting change could re-enable the warning.

Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → Wishlist
milestone: none → backlog
status: New → Confirmed
Changed in indicator-sound (Ubuntu):
assignee: nobody → Charles Kerr (charlesk)
Matthew Paul Thomas (mpt) wrote :

This is already covered in the spec: "Whenever you increase volume, *for the first time in 20 hours*, such that acoustic output would be more than 85 dBA..."

no longer affects: ubuntu-ux
description: updated
Changed in canonical-devices-system-image:
importance: Wishlist → High
Changed in indicator-sound (Ubuntu):
importance: Undecided → High
no longer affects: music-app
Changed in canonical-devices-system-image:
milestone: backlog → ww08-2016
Changed in indicator-sound (Ubuntu):
assignee: Charles Kerr (charlesk) → Xavi Garcia (xavi-garcia-mena)
Changed in canonical-devices-system-image:
status: Confirmed → Triaged
Changed in indicator-sound (Ubuntu):
status: New → Incomplete
Xavi Garcia (xavi-garcia-mena) wrote :

I thought I already added a comment on this one.

We had some changes regarding the warning dialog for OTA-9 and this bug seems to be fixed.

I marked as incomplete just to ask the reporter if the issue was happening only when the song finished and it was changing to the next one or if it also happened when pressing next on the indicator or the music-app.

Charles Kerr (charlesk) wrote :

Right, I think this is fixed by <https://code.launchpad.net/~charlesk/indicator-sound/volume-warning/+merge/281411> which landed about a week after pat's comment. The current behavior I'm seeing follows the spec as described by mpt.

Changed in canonical-devices-system-image:
milestone: ww08-2016 → ww02-2016
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers