ListItem needs keyboard focus support

Bug #1523815 reported by Christian Dywan on 2015-12-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu RTM)
High
Zsombor Egri

Bug Description

ListItem needs to be able to take focus via (Shift)Tab and render a rectangle in focus color.

Related branches

Zsombor Egri (zsombi) on 2015-12-08
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Christian Dywan (kalikiana) → Zsombor Egri (zsombi)
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww08-2016
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → High
Zsombor Egri (zsombi) on 2015-12-15
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: New → Invalid
status: Invalid → In Progress
importance: Undecided → High
assignee: nobody → Zsombor Egri (zsombi)
Zoltan Balogh (bzoltan) on 2015-12-22
no longer affects: ubuntu-ui-toolkit (Ubuntu)
Łukasz Zemczak (sil2100) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1795+15.04.20160106-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1795+15.04.20160106-0ubuntu1) vivid; urgency=medium

  [ Christian Dywan ]
  * Fix typo in runtest.sh: $? is the error code, not $*.
  * Document use of RegExpValidator for password/ PIN input.
  * Include filename derived QML class name in .api. Fixes LP: #1527138
  * Use edit-clear for clear button instead of the invalid clear search.
  * No transparency in focus outline.
  * Give the original Toolbar its name back.
  * Fix typo in runtest.sh: $? is the error code, not $*.
  * Use resolved filename but add fragment. Fixes LP: #1401920

  [ Zoltán Balogh ]
  * Use build root for the Gestures library instead of relative path.
  * Fix the tests for the gallery change

  [ Zsombor Egri ]
  * Add mnemonics support to Action. Fixes LP: #1527527
  * Use original Image.source in image extension when no scaling is needed in
    order to keep the formatting which would be otherwise removed from a
    resolved file URL. Fixes LP: #1401920
  * Move UbuntuListView 1.3 code into one single file. Fixes LP: #1523815

  [ Albert Astals Cid ]
  * Add UCTestExtras::removeTimeConstraintsFromSwipeArea
    For that needed to move ucswipearea.cpp from UbuntuComponents to
    UbuntuGestures but made it in a private header so we don't have to care much
    for the API/ABI stability for now.

  [ Andrea Bernabei ]
  * make scrollbars tests more robust.

  [ Tim Peeters ]
  * Update font sizes. Fixes LP: #1528263

  [ CI Train Bot ]
  * No-change rebuild.

ubuntu-ui-toolkit (1.3.1778+16.04.20151221-0ubuntu1) xenial; urgency=medium

  [ Tim Peeters ]
  * Fix issue with trigger() for ListItems.Standard. (LP: #1527811)

ubuntu-ui-toolkit (1.3.1778+16.04.20151217.1-0ubuntu1) xenial; urgency=medium

  [ Andrea Bernabei ]
  * Rework Scrollbars and add ScrollView component.

  [ Zsombor Egri ]
  * Refactor UCSwipeAreaPrivate to use QQuickItemPrivate instead of being
    a QObject.

  [ Tim Peeters ]
  * Reduce toolbar height on phone in landscape orientation.
    Fixes LP: #1336793.
  * Introduce the new Toolbar component for the header edit mode.
  * Reduce the PageHeader height by 1 GU on phone in landscape orientation.
    Fixes LP: #1336793
  * Fix AppHeader 1.2 to use the new MathUtils. This fixes a failing autopilot
    CPO test.

  [ Zoltan Balogh ]
  * Do not wipe when provisioning for normal use and improve
    regression detection.
  * Try to link Gestures more explicitely. (kudos to xnox).

  [ Christian Dywan ]
  * Proper keyboard navigation and focus visuals for buttons.
    Fixes LP: #1225139, LP: #1514850
  * Escape should close popover. Fixes LP: #1523828
  * Surround state overloading message with static boolean. Fixes LP: #1523399
  * Don't exit, return 1 from export_modules_dir.sh.

  [ Michael Sheldon ]
  * Set the activeFocus on the input component when a text input area receive
    focus. Fixes LP: #1518352

  [ Benjamin Zeller ]
  * Move PageTreeNode to C++.
  * Custom property flag needs to be set always even when the value itself does not chan...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: In Progress → Fix Released
Zoltan Balogh (bzoltan) on 2016-01-06
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
no longer affects: ubuntu-ui-toolkit (Ubuntu)
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Zsombor Egri (zsombi) wrote :

I rolled it back to "in progress" as only the prerequisite was landed, the actual fix is still in progress due to UX issues.

Changed in canonical-devices-system-image:
status: Fix Committed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: Fix Released → In Progress
Łukasz Zemczak (sil2100) wrote :
Download full text (8.5 KiB)

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1872+15.04.20160308-0ubuntu1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1872+15.04.20160308-0ubuntu1) vivid; urgency=medium

  [ Timo Jyrinki ]
  * Fix gles unit test skipping.
  * Add s390x to the unit test skipping architectures
  * UITK test plan - wily -> xenial. Fixes LP: #1544490

  [ Christian Dywan ]
  * Print errors when QuickUtils fails to create a component.
  * unit tests shouldn't use deprecated Dialog.callera
  * Correctly count only test case results. The result= value is used in suites
    and results.
  * Skip tst_pagehead_visible flakes on non-arm. Fixes LP: #1534651
  * Skip flaky tst_mousefilterTest::doubleClicked. Fixes LP: #1542215
  * Suppress click signal if releasing outside of ListItem. Fixes LP: #1541148.
  * Use gdb in runtest.sh to produce backtraces.
  * Arrow keys change value of a Slider. Fixes LP: #1523824.
  * Only use Maliit when enabled explicitly in the environment

  [ Oliver Tilloy ]
  * Do not try to assign to non-existent property "activeFocusOnPress".
    Fixes LP: #1532953
  * Bubble up ESC key press event if there is no popover to close.
    Fixes LP: #1546627

  [ Loïc Molinari ]
  * Added private items and nodes for the new component styles.
    Fixes LP: #1523836
  * Made use of new private Frame item for the focusing.
  * Fixed performance monitor crash because of a NULL timer pointer dereference.
    Fixes LP: #1546986
  * Fixed performance monitor dangling pointer crash. Fixes LP: #1546984
  * [ProportionalShape] Ensured width/height ratio is correct with default values.
    Fixes LP: #1546546
  * Added a workaround to prevent a crash while changing the QPA scale factor.

  [ Florian Boucault ]
  * Always on performance monitor that logs frames that too long to render.
  * MainView: proceed to selecting the theme automatically at startup too.
    Fixes LP: #1535819
  * MainView: when no gradient color is needed for the background, rely on
    QQuickWindow's GL clear color. Lessens overdraw considerably for most
    apps. Fixes LP: #1439133.
  * Panel: MathUtils used without import prefix was leading to undefined
    reference.
  * Label: use native rendering on low dpi screens (GRID_UNIT_PX <= 10) for
    sharper looking text.
  * Gallery: added palette browser to Colors page.

  [ Tim Peeters ]
  * Support scrolling in ListViews with horizontal orientation to the
    qquicklistview CPO.
  * Add background to AppHeader and remove contents clipping from MainView.
    Fixes LP: #1531016, LP: #1531457.
  * Hide AppHeader when using AdaptivePageLayout. Fixes bug 1531871.
    Fixes LP: #1531871.
  * Implement horizontal flicking in the flickable autopilot CPO.
  * Re-order to list of pages in the gallery to be alphabetical.
  * Fix the autopilot failures introduced with the horizontal scrolling in
    the Flickable CPO.
  * Update documentation for MainView, Page, AdaptivePageLayout to use the new
    PageHeader in all examples. Deprecate old properties. Fixes LP: #1540574
  * Add 'animate' property to new internal AppHeaderBase, and do not show a
    header anim...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: In Progress → Fix Released
Zoltan Balogh (bzoltan) on 2016-03-09
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Fix Released → Fix Committed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints