Accounts application file references non-existent service type

Bug #1520173 reported by Dave Morley on 2015-11-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Alejandro J. Cura

Bug Description

STEPS:
1. install 179 on arale
2. open settings
3. select accounts

EXPECTED:
I expect to see U1 listed

ACTUAL:
U1 is not listed in the add accounts page however you can still add it from telegram and apps store so the account is just missing from the add accounts page.

PROBABLE CAUSE:
I think that nothing actually says it depends on the account so is only accessed indirectly from apps scope and telelgram as neither show in u1 account page details.

Related branches

Dave Morley (davmor2) on 2015-11-26
tags: added: qa-manual-testing
tags: added: regression-proposed
Changed in canonical-devices-system-image:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → David Barth (dbarth)
milestone: none → ww02-2016
Alberto Mardegan (mardy) wrote :

Pay UI does not appear under the U1 account when it's opened from the System Settings. Therefore, as far as Online Accounts knows, there is no application using the U1 account. We recently landed a change to hide account providers for which there isn't an installed application which could make some use of the account.

PayUI ships an .application file, but it needs to ship a .service file as well. I'll try to prepare a MP for this.

affects: libaccounts-qt (Ubuntu) → pay-ui
Dave Morley (davmor2) wrote :

Possibly telegram too

Alberto Mardegan (mardy) wrote :

I've attached a branch for pay-ui, but I couldn't test it because I couldn't build the project in a click chroot: it depends on libubuntuoneauth-2.0-0:armhf, which in turns depend (why?) on account-plugin-tools which for some reason cannot be installed.
If someone would be so kind to build an armhf click out of this branch, I would happily test it and fix it if needed.

Pat McGowan (pat-mcgowan) wrote :

@alecu could you help here

Changed in canonical-devices-system-image:
assignee: David Barth (dbarth) → Alejandro J. Cura (alecu)
status: Confirmed → In Progress
Changed in pay-ui:
status: New → In Progress
importance: Undecided → Critical
Pat McGowan (pat-mcgowan) wrote :

@mardy do you want to propose an MR here

Changed in pay-ui:
assignee: nobody → Alberto Mardegan (mardy)
dobey (dobey) wrote :

Wait, what?

dobey (dobey) wrote :

This change makes no sense for the described problem, which is a regression in system-settings-online-accounts.

dobey (dobey) on 2015-12-07
summary: - ubuntuone account is missing from the add account list as it is not
- directly access from the installed scopes/apps
+ Accounts application file references non-existent service type
Changed in pay-ui:
assignee: Alberto Mardegan (mardy) → Rodney Dawes (dobey)
dobey (dobey) wrote :

After viewing mardy's branch, and trying a different quick fix on my phone for this, it is evident that the application file for payui is incorrect. The fix suggested by mardy's branch is also incorrect here, so I've proposed a separate branch to get around the online-accounts regression exposure, which is smaller and more direct.

I do however contend that there is still a regression in system-settings-online-accounts only displaying accounts in the "add account list" when registered applications are using them, versus unconfined applications. It means that for example, removing the Twitter web app will also make it no longer possible to add a Twitter account, even though it would be possible for account-polld to still use the account and provide notifications, which may be useful to some users. I don't know what online-acounts was trying to "fix" by implementing such a change, but in my opinion, it is not a solution, as it only breaks existing viable scenarios for adding accounts.

In this specific case, if pay-ui were to be uninstalled, even with this fix, the issue would still remain, even though the account would still be used by the app store, and by ubuntu-push. So while I'll agree that the pay-ui .application file is indeed partially incorrect, and I am proposing a fix for it, it is only a workaround for this immediate issue, and the regression still remains in online-accounts.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:pay-ui at revision 140, scheduled for release in pay-ui, milestone Unknown

Changed in pay-ui:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
dobey (dobey) on 2015-12-18
Changed in pay-ui:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers