Some media keys on keyboards do not work as expected

Bug #1519681 reported by Evan Wang on 2015-11-25
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Band-aids for Ubuntu Phone
Undecided
Unassigned
Canonical Pocket Desktop
Undecided
Unassigned
Canonical System Image
Critical
Unassigned
The Avila project
High
Unassigned
bluez (Ubuntu)
Undecided
Unassigned
qtubuntu-media (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
Undecided
Unassigned

Bug Description

$ system-image-cli -i
current build number: 75
device name: mako
channel: ubuntu-touch/rc-proposed/ubuntu-pd
last update: 2015-11-24 05:39:02
version version: 75
version ubuntu: 20151124
version device: 20150911
version custom: 20150929-2-vivid

Steps to reproduce:
1. Windowed mode is enabled with BT mouse/keyboard connected
2. Launch music app to play all of a playlist
3. Press Pause/Play, Fast forward/Rewind keys on BT keyboard

Actual results:
Press media keys(Pause/Play, Fast forward/Rewind) on BT keyboard has no control for playback
currently only Volume Up/ Down and Mute/Unmute media keys work

BT keyboard type: Logitech K480 and Rapoo E6350

tags: added: qa-frieza
John McAleely (john.mcaleely) wrote :

added unity8 & bluez. Not sure who decided what keycodes map to what.

Changed in avila:
milestone: none → ww06-2016
status: New → Confirmed
importance: Undecided → High
Michael Zanetti (mzanetti) wrote :

As of Bluez5, AVRCP does not inject keypresses any more, but bluez connects to MPRIS.

The issue is either in our bluez setup or the media-hub mpris interface

Changed in unity8 (Ubuntu):
status: New → Invalid
Pat McGowan (pat-mcgowan) wrote :

for me only volume keys work, not mute

Changed in canonical-devices-system-image:
assignee: nobody → John McAleely (john.mcaleely)
importance: Undecided → Critical
milestone: none → ww08-2016
status: New → Confirmed
tags: added: mwc
Pat McGowan (pat-mcgowan) wrote :

This would be more than handy for demos

Michał Sawicz (saviq) wrote :

I don't think this is AVRCP actually.

These are likely standard media key events delivered to the shell that just passes them down to apps today.

Changed in unity8 (Ubuntu):
status: Invalid → New
summary: - Some media keys on BT keyboard do not work as expected
+ Some media keys on keyboards do not work as expected
Simon Fels (morphis) wrote :

It hardly depends on what the keyboard supports. Check via bluetoothctl which profiles it supports. If its only HID then its not AVRCP but otherwise it could and then we have to fix this differently.

Pat McGowan (pat-mcgowan) wrote :

The K480 reports:
Class: 000540
UUID: Service DIscovery
UUID: Human Interface Device
UUID: PnP Information

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez (Ubuntu):
status: New → Confirmed
Changed in qtubuntu-media (Ubuntu):
status: New → Confirmed
Changed in unity8 (Ubuntu):
status: New → Confirmed
Simon Fels (morphis) on 2016-03-10
tags: added: bluetooth-ota10
Changed in canonical-devices-system-image:
milestone: ww08-2016 → backlog
Jim Hodapp (jhodapp) on 2016-05-10
Changed in qtubuntu-media (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → nobody
tags: added: bluez-touch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers