After a boot the dash doesn't display until touched

Bug #1515356 reported by Pat McGowan on 2015-11-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
kevin gunn
qtmir (Ubuntu)
High
Nick Dedekind
qtubuntu (Ubuntu)
High
Nick Dedekind

Bug Description

Saw this on 162 and 163
MX4
also on krillin and mako

Get the update and reboot to install, open the greeter, there is a blank screen with just the bottom edge hint
touch the screen and it displays the scope contents immediately

Also reproduces frequently after reboot

Related branches

Pat McGowan (pat-mcgowan) wrote :

seems like a recent regression

description: updated
Changed in unity8 (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww46-2015
status: New → Confirmed
assignee: nobody → Pat McGowan (pat-mcgowan)
summary: - Firs boot after an update the dash doesn't display until touched
+ After a boot the dash doesn't display until touched
description: updated
Changed in unity8 (Ubuntu):
status: Confirmed → New
Pat McGowan (pat-mcgowan) wrote :

 apt-cache policy qtdeclarative5-qtmir-plugin
qtdeclarative5-qtmir-plugin:
  Installed: 0.4.6+15.04.20151110-0ubuntu1
  Candidate: 0.4.6+15.04.20151110-0ubuntu1

kevin gunn (kgunn72) wrote :

OK, verified that Pat didn't see this on 161, i flashed on MX4 and i didn't see either.
all the qtmir/qtubuntu updates were already in 161 so i updated and witnessed the problem

here were the list of updates

The following packages will be upgraded:
  coreutils dialer-app indicator-sound language-pack-touch-ast language-pack-touch-bg language-pack-touch-bs
  language-pack-touch-ca language-pack-touch-cs language-pack-touch-da language-pack-touch-de
  language-pack-touch-el language-pack-touch-en language-pack-touch-es language-pack-touch-eu
  language-pack-touch-fi language-pack-touch-fr language-pack-touch-gl language-pack-touch-he
  language-pack-touch-hu language-pack-touch-id language-pack-touch-it language-pack-touch-ja
  language-pack-touch-ko language-pack-touch-lt language-pack-touch-lv language-pack-touch-ms
  language-pack-touch-nb language-pack-touch-nl language-pack-touch-oc language-pack-touch-pl
  language-pack-touch-pt language-pack-touch-ro language-pack-touch-ru language-pack-touch-sk
  language-pack-touch-sl language-pack-touch-sr language-pack-touch-sv language-pack-touch-tr
  language-pack-touch-ug language-pack-touch-uk language-pack-touch-zh-hans language-pack-touch-zh-hant
  libubuntu-location-service2 ubuntu-location-service-bin

kevin gunn (kgunn72) wrote :

scratch that - retested fresh 161 and i see the issue

kevin gunn (kgunn72) wrote :

ok, went back to 159, verified no issue after several reboots.
updated only qtmir/qtubuntu to the very latest and the issue appeared on the first reboot.

so these 2 changes are the suspects
https://code.launchpad.net/~unity-team/qtmir/revert-occlusion-detection/+merge/277049
https://code.launchpad.net/~unity-team/qtubuntu/revert-occlusion-detection/+merge/277048

Changed in qtmir (Ubuntu):
importance: Undecided → High
no longer affects: unity8 (Ubuntu)
Changed in qtubuntu:
importance: Undecided → High
Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → kevin gunn (kgunn72)
Changed in qtubuntu:
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in qtmir (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
tags: added: regression-proposed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
kevin gunn (kgunn72) wrote :

just an update - we could completely revert the occlusion changes back to a couple of weeks ago to get back to the original baseline. however there is a real issue where qtmir is getting confused due to some buffer dropping logic and getting out of sync with what actually needs updating. our preference is to spend the time to actually correct this problem rather than further feature reverting

Changed in qtubuntu:
status: New → In Progress
Changed in qtmir (Ubuntu):
status: New → In Progress
tags: added: lt-blocker lt-category-visible
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Jean-Baptiste Lallement (jibel) wrote :

Still affecting devel-proposed.

tags: added: devel-proposed
Gerry Boland (gerboland) wrote :

qtmir release fixing this blocked in migration, due to liburcu issue

kevin gunn (kgunn72) wrote :

librcu is being addressed i think, should be resolve very soon per bug 1511458
which references
https://portal.admin.canonical.com/85976

Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.6+16.04.20151113-0ubuntu1

---------------
qtmir (0.4.6+16.04.20151113-0ubuntu1) xenial; urgency=medium

  [ Nick Dedekind ]
  * Update surface textures when dropping frames. (LP: #1515356)

 -- Gerry Boland <email address hidden> Fri, 13 Nov 2015 16:42:38 +0000

Changed in qtmir (Ubuntu):
status: In Progress → Fix Released
tags: removed: lt-blocker lt-category-visible
Michał Sawicz (saviq) on 2016-09-06
Changed in qtubuntu:
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2017-03-13
affects: qtubuntu → qtubuntu (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers