Nearby scope is blank with nominatim enabled.

Bug #1515182 reported by Jean-Baptiste Lallement on 2015-11-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
Penk Chen
The Savilerow project
Critical
Zhang Enwei

Bug Description

current build number: 172
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en

Reproduced on arale too.

The Nearby scope is blank, just the cateregory dropdown is displayed but no content. If I disable location it displayed static content.
If I disable nominatim and location is enabled, then it displayed the usual content.

scope-registry.log attached.

At the beginning of the log there is this message:
panic: invalid character '0' looking for beginning of object key string

goroutine 20 [running]:
runtime.panic(0x24e290, 0x9420e550)
        /usr/lib/go/src/pkg/runtime/panic.c:279 +0x1a0
launchpad.net/go-unityscopes/v1.(*SearchMetadata).Location(0x94208348, 0x0)
        /home/enwei/demo/backup/nominatim/src/go/src/launchpad.net/go-unityscopes/v1/metadata.go:74 +0x170
main.(*WikiNearScope).Search(0x941d2450, 0x94208338, 0x94208348, 0x9420e4f8, 0x94202380, 0x0, 0x0)
        /home/enwei/demo/backup/nominatim/src/nominatim.go:255 +0x6c
launchpad.net/go-unityscopes/v1.func·001()
        /home/enwei/demo/backup/nominatim/src/go/src/launchpad.net/go-unityscopes/v1/unityscope.go:51 +0x80
created by launchpad.net/go-unityscopes/v1.callScopeSearch
        /home/enwei/demo/backup/nominatim/src/go/src/launchpad.net/go-unityscopes/v1/unityscope.go:57 +0x150

goroutine 16 [syscall]:
launchpad.net/go-unityscopes/v1._Cfunc_run_scope(0x942082e8, 0x942080f0, 0x94208108, 0x942082e0, 0x942082f0)
        launchpad.net/go-unityscopes/v1/_obj/_cgo_defun.c:334 +0x34
launchpad.net/go-unityscopes/v1.Run(0x84094400, 0x941d2450, 0x0, 0x0)
        /home/enwei/demo/backup/nominatim/src/go/src/launchpad.net/go-unityscopes/v1/unityscope.go:145 +0x324
main.main()
        /home/enwei/demo/backup/nominatim/src/nominatim.go:329 +0xd8

goroutine 19 [finalizer wait]:
runtime.park(0x35d18, 0x3b96f0, 0x3a7c09)
        /usr/lib/go/src/pkg/runtime/proc.c:1369 +0x5c
runtime.parkunlock(0x3b96f0, 0x3a7c09)
        /usr/lib/go/src/pkg/runtime/proc.c:1385 +0x40
runfinq()
        /usr/lib/go/src/pkg/runtime/mgc0.c:2644 +0xa0
runtime.goexit()
        /usr/lib/go/src/pkg/runtime/proc.c:1445

goroutine 17 [syscall]:
runtime.goexit()
        /usr/lib/go/src/pkg/runtime/proc.c:1445

goroutine 18 [syscall]:
runtime.goexit()
        /usr/lib/go/src/pkg/runtime/proc.c:1445

Jean-Baptiste Lallement (jibel) wrote :
Changed in canonical-devices-system-image:
importance: Undecided → Critical
status: New → Confirmed
milestone: none → ww46-2015
assignee: nobody → Penk Chen (penk)
Jin (jindallo) wrote :

This symptom happens in latest nominatim 1.0.9 with specific position,
older version 1.0.2 does not have this issue.

The OLDER click 1.0.2 is attached.

Penk Chen (penk) wrote :

We're reverting changes in 1.0.9 and release an old (bumped version) nominatim 1.0.10 scope for OTA-8. When this bug being fixed it'll be release through store as well as next OTA.

Changed in savilerow:
importance: Undecided → Critical
status: New → Confirmed
assignee: nobody → Zhang Enwei (zhangew401)
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in savilerow:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Zhang Enwei (zhangew401) on 2015-11-12
Changed in savilerow:
status: In Progress → Fix Committed
Elsa Wang (elsawang) wrote :

@Evan, could you please help to verify this issue? Thanks.

Changed in savilerow:
assignee: Zhang Enwei (zhangew401) → Evan Wang (wsy324)
Zhang Enwei (zhangew401) wrote :
Evan Wang (wsy324) wrote :

Unable to reproduce the Nearby scope blank issue with new click "com.canonical.scopes.nominatim_1.0.11_armhf.click"
But, for some locations the address formats are different than we tested with each click of each location before, please refer to below results (the upper ones are old results), please help to confirm which format is expected.

lat=52.5167 & lon=13.3833 //Germany
formated_name: Unter den Linden, 10117, Berlin, Deutschland
formated_name: Unter den Linden, Berlin, 10117, Deutschland

> lat=51.5062348 & lon=-0.0999525 //London
formated_name: Blue Fin Building, Southwark Street, SE1 0NZ, London,United Kingdom
formated_name: Blue Fin Building, Southwark Street, London, England, SE1 0NZ, United Kingdom

> lat=39.9235&lon=116.4034 //Beijing
formated_name: 中国, 北京市, 五四大街
formated_name: 五四大街, 北京市, 100010, 中国

> lat=40.452587;lon=-3.693831//Spain
formated_name: Avenida del General Perón, 36, 28020, Madrid, España
formated_name: 36, Avenida del General Perón, Madrid, Comunidad de Madrid, 28020, España

> lat, lon = 22.755954, 77.740116//indian
formated_name: SH22, Hoshangābād, Madhya Pradesh, India
formated_name: SH22, Hoshangābād, Madhya Pradesh, India

> lat=64.269278;lon=100.217653//Russia
formated_name: Колхозная улица, сельское поселение Тура, Россия
formated_name: Колхозная улица, сельское поселение Тура, Красноярский край, Россия

> lat=38.459216;lon=-98.539594//american
formated_name: Northeast 130 Avenue, Barton County, Kansas, 67525, United States of America
formated_name: Northeast 130 Avenue, Barton County, Kansas, 67525, United States of America

> lat=46.645122;lon=2.218117//France
formated_name: D 70, 18170, Maisonnais, France
formated_name: D 70, Maisonnais, Centre-Val de Loire, 18170, France

> lat=41.888844;lon=12.538363//Italy
formated_name: Via Renzo Da Ceri, 00177, Roma, Italia
formated_name: Via Renzo Da Ceri, Roma, LAZ, 00177, Italia

> lat=46.928585;lon= //Switzerland
formated_name: Heimweg, 9, 3097, Köniz, Schweiz, Suisse, Svizzera, Svizra
formated_name: 9, Heimweg, Köniz, Bern - Berne, 3097, Schweiz, Suisse, Svizzera, Svizra

Changed in savilerow:
assignee: Evan Wang (wsy324) → Zhang Enwei (zhangew401)
Zhang Enwei (zhangew401) wrote :

Hi Evan,
have you changed the system language before the test?
thanks.

Evan Wang (wsy324) wrote :

Ah..,right,sorry for that, so the address formats are as expected as well if changed the system language accordingly.

tags: added: cqa-verified
removed: regression-proposed
Jean-Baptiste Lallement (jibel) wrote :

Please leave the tags regression-*, it is used to track issues that escaped testing.

tags: added: regression-proposed
Zhang Enwei (zhangew401) wrote :

Thank you Evan for the effort.

Penk Chen (penk) wrote :

click pushed into repository and will be available in next OTA (OTA-9). Mark as fix released.

Changed in savilerow:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers