OptionSelector does not work with keyboard

Bug #1514860 reported by Renato Araujo Oliveira Filho on 2015-11-10
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
Critical
Christian Dywan

Bug Description

OptionSelector does not fully work with only keyboard. There is no way to select a option on OptionSelector using only the keyboard.

Pressing the arrows does not navigate on the options. And it does not have any visual feedback that it contains focus.

Related branches

Bill Filler (bfiller) on 2015-11-10
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww02-2016
importance: Undecided → High
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High
Zsombor Egri (zsombi) wrote :

True, no focus handling is performed on any component, and this belongs to the focus handling, as the expansion, navigation requires the component to be focused.

Beside, this component requires heavy redesign.

tags: added: convergence
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Triaged
Changed in canonical-devices-system-image:
status: New → Confirmed
Zoltan Balogh (bzoltan) on 2015-11-23
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Zoltan Balogh (bzoltan) → Christian Dywan (kalikiana)
Zoltan Balogh (bzoltan) on 2015-12-07
affects: ubuntu-ui-toolkit (Ubuntu) → ubuntu-ui-toolkit (Ubuntu RTM)
Zoltan Balogh (bzoltan) on 2015-12-14
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
importance: High → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Zoltan Balogh (bzoltan) on 2015-12-16
no longer affects: ubuntu-ui-toolkit (Ubuntu)
Zsombor Egri (zsombi) wrote :

We need visuals and key interaction input, the earliest we can have this is OTA10.

Christian Dywan (kalikiana) wrote :

This depends on bug 1523815 unfortunately, it needs the same visuals and UX.

Changed in canonical-devices-system-image:
milestone: ww02-2016 → ww08-2016
Changed in canonical-devices-system-image:
milestone: ww08-2016 → 11
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Triaged
assignee: nobody → Christian Dywan (kalikiana)
importance: Undecided → Critical
Zsombor Egri (zsombi) on 2016-04-27
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Christian Dywan (kalikiana) → Zsombor Egri (zsombi)
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
assignee: Christian Dywan (kalikiana) → Zsombor Egri (zsombi)
Changed in canonical-devices-system-image:
milestone: 11 → 12
Changed in canonical-devices-system-image:
milestone: 12 → 13
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Zsombor Egri (zsombi) → Christian Dywan (kalikiana)
no longer affects: ubuntu-ui-toolkit (Ubuntu RTM)
Changed in canonical-devices-system-image:
milestone: 13 → backlog
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (4.4 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2135+16.10.20161003.1

---------------
ubuntu-ui-toolkit (1.3.2135+16.10.20161003.1) yakkety; urgency=medium

  [ Christian Dywan ]
  * Fix warning about using implicit char* to QString conversion.
  * __styleInstance may be null, when doesn't handle that. Fixes LP: #1586013
  * Focus ring, arrow keys and space to expand OptionSelector.
    Fixes LP: #1514860
  * Use QStringLiteral with QString.replace. Fixes LP: #1625507
  * Use displayText to determine if the clear button should show.
    Fixes LP: #1461571
  * && escapes an ampersand used in a mnemonic label. Fixes LP: #1587580
  * Try harder to pass an item to QuickUtils.rootItem. Fixes LP: #1586013

  [ Timo Jyrinki ]
  * Enable arm64 unit tests on xenial and newer. Fixes LP: #1580172.
  * Add initial snapcraft.yaml

  [ Marco Trevisan ]
  * UCSlotsLayout: update the size of the element when top/bottom paddings change.
    Fixes LP: #1628161

  [ Tim Peeters ]
  * Ensure that the model in TabBarStyle is a list and not null.
    Fixes LP: #1622577.
  * Initialize the 'window' context property with null and add MainView 1.3 unit
    tests. Fixes LP: #1610231, LP: #1621509, LP: #1625993.
  * Fix libpng sRGB profile warnings on Yakkety. Fixes LP: #1625137.
  * Disable layouts unit test to work around bug 1625137 on Yakkety.

  [ Zsombor Egri ]
  * Fix AdaptivePageLayout behavior on Qt5.6. Fixes LP: #1585996.
  * Fix property binding restore on theme palette values. Fixes LP: #1570478.
  * Move activeFocusOnTab from style into components. Fixes LP: #1590005.

  [ Loïc Molinari ]
  * Added public headers extra robustness checks. Made use of the qmake
    headersclean feature to check the robustness of our public headers.
  * Excluded LTTng features from non-Linux builds.
  * Moved common C++ configs to ubuntu_common.prf. The common config file
    doesn't add -Werror directly to QMAKE_CXXFLAGS anymore, it sets the
    warnings_are_errors variable so that it is correctly handled by different
    compilers (not just GCC). That allows to remove the
    -Werror=deprecated-declarations flag since warnings_are_errors defines it
    for us. Removed the DEFINES += QT_USE_QSTRINGBUILDER lines since it's
    already handled by qt_module.prf. Set the -Wsuggest-override warning to
    QMAKE_CXXFLAGS_WARN_ON instead of QMAKE_CXXFLAGS directly.
  * Cleaned up qmake Ubuntu packaging variables. The qtbase packaging for Ubuntu
    exports the CFLAGS, CXXFLAGS and LFLAGS variables in the environment before
    running configure so that the qtbase shared libraries can be compiled with
    the required distribution defined compiler flags. That is fine (though I
    guess that could be handled better at the qtbase packaging level with maybe
    a dedicated prf) but it results in qt_build_config.prf defining the
    QMAKE_CFLAGS, QMAKE_CXXFLAGS and QMAKE_LFLAGS variables with these
    distribution specific flags. Since we load this prf, these variables end up
    being defined when building the toolkit for development purpose. This is
    problematic because -O2 and -g are always defined (whatever the debug or
    release config chosen by the developer), al...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints