With occlusion detection, apps stop responding when switching from another app.

Bug #1514556 reported by Nick Dedekind on 2015-11-09
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
kevin gunn
qtmir (Ubuntu)
Critical
Nick Dedekind
qtubuntu (Ubuntu)
Critical
Nick Dedekind

Bug Description

If you switch from one app to the next, and start scrolling around (eg in dash) very soon after switching, the app will sometimes stop rendering.

Reproduce:
1) Start an app (eg dialer) from dash
2) wait a few seconds in dialer.
3) Do a quick switch back to dash, and immediately start scrolling/swiping around.

Expected:
app behaves normally and responds to user input.

Actual:
sometimes the dash will stop responding for an undetermined amount of time, or until you interact with another part of the shell.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

regression from last qtmir landing

Changed in canonical-devices-system-image:
assignee: nobody → kevin gunn (kgunn72)
importance: Undecided → Critical
milestone: none → ww46-2015
status: New → In Progress
no longer affects: unity8 (Ubuntu)
Changed in qtmir (Ubuntu):
status: New → Confirmed
Changed in qtubuntu (Ubuntu):
status: New → Confirmed
Changed in qtmir (Ubuntu):
importance: Undecided → Critical
Changed in qtubuntu (Ubuntu):
importance: Undecided → Critical
Changed in qtmir (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Changed in qtubuntu (Ubuntu):
assignee: nobody → Nick Dedekind (nick-dedekind)
Nick Dedekind (nick-dedekind) wrote :

Testing in Ubuntu 15.04 (r168):

This problem seems to be related to mir dropping old buffers when the visibility changes from occluded->exposed.
If I remove the "drop old buffers" code from mir::scene::BasicSurface::set_visibility, then it seems to come right.

There have been some changes in mir related to the buffer stream and arbiter which I'm testing if might make a difference. It may also be that we're not handling the dropped buffers correctly in qtmir?

tags: added: regression-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtubuntu - 0.62+16.04.20151109-0ubuntu1

---------------
qtubuntu (0.62+16.04.20151109-0ubuntu1) xenial; urgency=medium

  [ Nick Dedekind ]
  * Reverted occlusion detection (lp#1514556) (LP: #1514556)

 -- Gerry Boland <email address hidden> Mon, 09 Nov 2015 22:43:18 +0000

Changed in qtubuntu (Ubuntu):
status: Confirmed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtmir - 0.4.6+16.04.20151113-0ubuntu1

---------------
qtmir (0.4.6+16.04.20151113-0ubuntu1) xenial; urgency=medium

  [ Nick Dedekind ]
  * Update surface textures when dropping frames. (LP: #1515356)

 -- Gerry Boland <email address hidden> Fri, 13 Nov 2015 16:42:38 +0000

Changed in qtmir (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers