Network errors after changing between mobile data connection and wifi

Bug #1506015 reported by Victor gonzalez on 2015-10-14
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Alejandro J. Cura
qtbase-opensource-src (Ubuntu)
Undecided
Unassigned
qtbase-opensource-src (Ubuntu RTM)
Undecided
Unassigned
unity-scope-click (Ubuntu)
High
dobey

Bug Description

Customer reported this behaviour to bq support department regarding Ubuntu Core apps, but I reproduced it when looking for any app in Ubuntu Store

Product: bq Aquaris E4.5 & E5
FW version: r25,r5
HW version: MP

PRECONDITIONS: I was able to repro this after changing several times between mobile data connection and wifi with the Ubuntu store open.

STEPS TO REPRO:
1. Go to Ubuntu Store
2. Look for some Ubuntu core apps( terminal, File manager for example )

Actual Result:
Cannot find no app in Ubuntu store
Expected Result:
Every search should show an apps list as a result

Additional info: syslog and video attached

Tags: bq Edit Tag help
description: updated
John McAleely (john.mcaleely) wrote :

I confirmed this behaviour on the duped oem bug

Changed in canonical-devices-system-image:
milestone: none → ww46-2015
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
importance: Undecided → High
dobey (dobey) wrote :

Can this still be recreated? If so, please attach the ~/.cache/upstart/scope-registry.log file from when this occurs. Also, please verify that the network is generally usable. Try opening https://search.apps.ubuntu.com/api/v1/package/com.ubuntu.terminal in the browser for example.

Thanks.

I've got a customer right now with this bug. We´ll ask the customer to reproduce it again and get the logs suggested =)

Here is the attachment of image and logs from the customer that reproduced the bug. Please note that he was in R19(he did not receive OTA notifications and we're still wating to know if he had R/W permission enabled).

If we do find more users we'll try to gather some more logs.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
dobey (dobey) wrote :

Unfortunately the log in that zip file is not useful. For some reason it contains the output of "adb --help" rather than actual log contents.

The screenshot is also not helpful, though it does appear to have an extremely old bug, where the volume notification would pop up and appear in the screenshot, indicating that it is perhaps a very old image, and does not have the 15.04 framework. Please verify that customer has installed the latest system image update, and is still not able to see the Terminal application in search results. That seems to be a different issue than the one reported in this bug.

If you are capable of recreating the original issue yourself, please attach the scope-registry.log from when you have made the issue occur, and verify if you are capable of opening https://search.apps.ubuntu.com/api/v1/package/com.ubuntu.terminal in the browser. Thanks.

Changed in unity-scope-click (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
status: Confirmed → Incomplete
Changed in canonical-devices-system-image:
status: Confirmed → Incomplete

I'm on it, I'll try to repro and attach new fresh logs =)

Here are the logs. For additional info:

- Bug reproduced with Vegeta in french language.
- Firmware versión R6
- Attached video with the bug, screenshot accesing https://search.apps.ubuntu.com/api/v1/package/com.ubuntu.terminal after bug was reproduce and the scope-registry.log

wow I forgot to mention that after reboot it was all ok and vegeta was able to find apps in Ubuntu store

dobey (dobey) wrote :

Looking at the log, it seems all scopes are not able to access the network. Is it possible to use the eBay or Amazon scopes when this issue occurs?

Changed in unity-scope-click (Ubuntu):
status: Incomplete → Confirmed
Changed in canonical-devices-system-image:
status: Incomplete → Confirmed
milestone: ww46-2015 → ww02-2016

Hi,

After the bug was reproduced once again, I did the following procedure:

12:10 --> Search "Cloud" on Ubuntu Store --> Got white page, no results shown.
12:11 --> Tried to access Amazon and got Network error
12:11 --> Tried to access eBay and it worked, no network error
12:11/12:12 --> Search "Cloud" again on Ubuntu Store, it worked .

As I didn't know which logs were the best ones I pulled everything. File attached content is /var/log* + scope-registry + crash

Alejandro J. Cura (alecu) wrote :

The bug description mentions that this problem was seen first with some core apps, and comment #13 mentions that at the time of this problem it was not possible to access Amazon either. So, this should not be a problem in the click scope. I'm marking that as invalid.

Changed in unity-scope-click (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
assignee: Alejandro J. Cura (alecu) → nobody
summary: - Cannot find apps in Ubuntu Store
+ Network errors after changing between mobile data connection and wifi
dobey (dobey) wrote :

Victor, was this last test using the Amazon and eBay scopes, or the web apps?

Hi Rodney,

I used the webapps for the tests

Pat McGowan (pat-mcgowan) wrote :

The description was that they were looking for the apps not using them

Changed in unity-scope-click (Ubuntu):
status: Invalid → Confirmed
importance: Undecided → High
Pat McGowan (pat-mcgowan) wrote :

As I recall scopes use a different API to detect network connectivity? i.e. not through Qt

Changed in canonical-devices-system-image:
assignee: nobody → Alejandro J. Cura (alecu)
dobey (dobey) wrote :

@Pat No, the click scope uses Qt for performing network requests. We don't query for connectivity at all, and simply rely on Qt to handle that.

Changed in canonical-devices-system-image:
milestone: ww02-2016 → ww08-2016
Lorn Potter (lorn-potter) wrote :

Silos 032 (vivid) and 057 (xenial) have a few patches/fixes to QNAM & friends that I believe will fix this issue

Timo Jyrinki (timo-jyrinki) wrote :

Silo 032 has long pending networking fixes that now have seen more recent work and the silo might be in shape for landing.

As an interested party in this networking related bug (among many), could you please give 032 a whirl on vivid-overlay (xenial also available) and test your networking in general in addition to this particular bug? If we see no regressions - and we do see fixes - we could try landing the silo.

Upgrade with 'citrain device-upgrade 32 0000'.

Lorn Potter (lorn-potter) wrote :

Retested with 032, and this was working for me.

dobey (dobey) wrote :

@Timo With silo 032 on my mako, the weather app is acting strangely. It's showing the current weather, and then immediately replaces it with a Network Error page. I'm not sure if this due to the silo, or something breaking in weather app.

Timo Jyrinki (timo-jyrinki) wrote :

@Rodney: The silo has now been updated a couple of times since. I'm familiar with that error from the past but not seeing it with the latest patches. It was/is related to apparmor denials.

It's notable that the full 032 needs to be updated, including the ubuntu-touch-session that adds a file in /etc/profile.d that keeps network-manager backend as new upstream logic would otherwise change the default.

Timo Jyrinki (timo-jyrinki) wrote :

This bug may be fixed by the 032 fixes if its the Qt side. Know bugs like bug #1470700 and bug #1528886 get fixed with the silo.

dobey (dobey) wrote :

OK, I will try to find some time to test this again with latest 032 after dealing with my current silo landing, and doing a reflash and cleaning out the sources.list.d. Unfortunately, I've never been able to really hit the network errors condition myself, so I'm not sure I'll be able to actively test it. However, rvr seems to be hitting some of these issues lately, so perhaps I will ask him to see if this silo helps at all, after I give it a quick general run through as well.

Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package qtbase-opensource-src 5.4.1+dfsg-2ubuntu11~vivid4 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

qtbase-opensource-src (5.4.1+dfsg-2ubuntu11~vivid4) vivid; urgency=medium

  * Lorn Potter's networking fixes:
    - debian/patches/Make-sure-to-report-correct-NetworkAccessibility.patch
    - debian/patches/Make-sure-networkAccessibilityChanged-is-emitted.patch
    - debian/patches/Fix-hang-in-qnam-when-disconnecting.patch
    - debian/patches/Make-UnknownAccessibility-not-block-requests.patch
    - debian/patches/qnam-ubuntu-fix6.patch (not yet upstreamed)
    (LP: #1470700) (LP: #1506015) (LP: #1507769) (LP: #1528886) (LP: #1533508)
  * debian/patches/Add-an-option-to-skip-the-generic-bearer-engine.patch
    - Backport to replace disable-generic-plugin-when-others-available.patch

 -- Timo Jyrinki <email address hidden> Mon, 14 Dec 2015 12:53:41 +0000

Changed in qtbase-opensource-src (Ubuntu RTM):
status: New → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

This bug maybe be the same as bug #1533508 which would mean the Qt fixes aren't helping here. But if there's a Qt aspect to the bug - for example the network not being broken elsewhere but just store results not working when switching between connections - it could be now fixed as Qt better reports the connectivity.

Timo Jyrinki (timo-jyrinki) wrote :

The comment #13 sounds like QNAM related so this bug can be marked as fixed. Let's keep the bug #1533508 there for what's probably lower level connectivity related problems.

Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtbase-opensource-src - 5.5.1+dfsg-13ubuntu2

---------------
qtbase-opensource-src (5.5.1+dfsg-13ubuntu2) xenial; urgency=medium

  * Forward-port networking fixes from 5.4 series:
    - net-bearer-nm-disconnect-ap-signals7.patch (LP: #1480877)
    - qnam-ubuntu-fix6.patch (LP: #1528886)
    - xenial would potentially now have fixes for (LP: #1506015)
      (LP: #1507769) (LP: #1533508)

 -- Timo Jyrinki <email address hidden> Tue, 09 Feb 2016 08:19:43 +0000

Changed in qtbase-opensource-src (Ubuntu):
status: New → Fix Released
dobey (dobey) on 2016-03-10
Changed in unity-scope-click (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers