rc-proposed contains three versions of Mir: 0.17.1 + 0.14.1 + 0.13.3

Bug #1498281 reported by Daniel van Vugt on 2015-09-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Pat McGowan
platform-api
Undecided
Thomas Voß
platform-api (Ubuntu)
Undecided
Thomas Voß

Bug Description

rc-proposed contains three versions of Mir: 0.15.1 + 0.14.1 + 0.13.3

$ dpkg -l | grep libmir
ii libmirclient-debug-extension1:armhf 0.15.1+15.04.20150903-0ubuntu1 armhf Display server for Ubuntu - optional client debug interfaces
ii libmirclient8:armhf 0.13.3+15.04.20150617-0ubuntu1 armhf Display server for Ubuntu - client library
ii libmirclient9:armhf 0.15.1+15.04.20150903-0ubuntu1 armhf Display server for Ubuntu - client library
ii libmircommon4:armhf 0.13.3+15.04.20150617-0ubuntu1 armhf Display server for Ubuntu - shared library
ii libmircommon5:armhf 0.15.1+15.04.20150903-0ubuntu1 armhf Display server for Ubuntu - shared library
ii libmirplatform9:armhf 0.15.1+15.04.20150903-0ubuntu1 armhf Display server for Ubuntu - platform library
ii libmirprotobuf0:armhf 0.14.1+15.04.20150821-0ubuntu1 armhf Display server for Ubuntu - RPC definitions
ii libmirprotobuf1:armhf 0.15.1+15.04.20150903-0ubuntu1 armhf Display server for Ubuntu - RPC definitions
ii libmirserver33:armhf 0.15.1+15.04.20150903-0ubuntu1 armhf Display server for Ubuntu - server library

It appears the main reason for the older packages still being present is platform-api depending on libmirclient8:

$ dpkg -s ubuntu-application-api2-touch
Package: ubuntu-application-api2-touch
Status: install ok installed
Priority: optional
Section: libs
Installed-Size: 361
Maintainer: Ubuntu Developers <email address hidden>
Architecture: armhf
Multi-Arch: same
Source: platform-api
Version: 2.9.0+15.04.20150326-0ubuntu1
Depends: libc6 (>= 2.17), libdbus-cpp4 (>= 2.0.0+14.04.20140310), libgcc1 (>= 1:4.4.0), libhybris-common1, libmirclient8 (>= 0.12.0+15.04.20150228), libstdc++6 (>= 4.9), libubuntu-location-service2, liburl-dispatcher1 (>= 0.1), libubuntu-application-api2 (= 2.9.0+15.04.20150326-0ubuntu1)
Pre-Depends: multiarch-support
Description: Implementation of the Platform API for Ubuntu Touch
 This package provides the implementation of the Platform API to
 bring up an Ubuntu Touch system.
Homepage: https://launchpad.net/platform-api

$ system-image-cli -i
current build number: 118
device name: arale
channel: ubuntu-touch/rc-proposed/meizu.en
last update: 2015-09-22 03:17:29
version version: 118
version ubuntu: 20150921
version device: 20150818-0b38025
version custom: 20150814-887-8-46

Daniel van Vugt (vanvugt) wrote :

This bug only seems to exist in vivid+overlay. On wily it does not happen because wily has ubuntu-application-api3-touch which depends on libmirclient9.

description: updated
Daniel van Vugt (vanvugt) wrote :

Still happening...

$ system-image-cli -i
current build number: 256
device name: mako
channel: ubuntu-touch/rc-proposed/ubuntu
last update: 2015-10-02 06:05:37
version version: 256
version ubuntu: 20151002
version device: 20150911
version custom: 20151002

$ dpkg -l | grep libmir
ii libmirclient-debug-extension1:armhf 0.16.0+15.04.20150921.1-0ubuntu1 armhf Display server for Ubuntu - optional client debug interfaces
ii libmirclient8:armhf 0.13.3+15.04.20150617-0ubuntu1 armhf Display server for Ubuntu - client library
ii libmirclient9:armhf 0.16.0+15.04.20150921.1-0ubuntu1 armhf Display server for Ubuntu - client library
ii libmircommon4:armhf 0.13.3+15.04.20150617-0ubuntu1 armhf Display server for Ubuntu - shared library
ii libmircommon5:armhf 0.16.0+15.04.20150921.1-0ubuntu1 armhf Display server for Ubuntu - shared library
ii libmirplatform10:armhf 0.16.0+15.04.20150921.1-0ubuntu1 armhf Display server for Ubuntu - platform library
ii libmirprotobuf0:armhf 0.14.1+15.04.20150821-0ubuntu1 armhf Display server for Ubuntu - RPC definitions
ii libmirprotobuf2:armhf 0.16.0+15.04.20150921.1-0ubuntu1 armhf Display server for Ubuntu - RPC definitions
ii libmirserver34:armhf 0.16.0+15.04.20150921.1-0ubuntu1 armhf Display server for Ubuntu - server library

summary: - rc-proposed contains three versions of Mir: 0.15.1 + 0.14.1 + 0.13.3
+ rc-proposed contains three versions of Mir: 0.16.0 + 0.14.1 + 0.13.3

So are these version compatible with each other? I am confused a bit since there are only single instances of packages not multiple

Changed in canonical-devices-system-image:
assignee: nobody → kevin gunn (kgunn72)
importance: Undecided → High
status: New → Confirmed
Changed in platform-api:
assignee: nobody → Thomas Voß (thomas-voss)
Changed in platform-api (Ubuntu):
assignee: nobody → Thomas Voß (thomas-voss)
Daniel van Vugt (vanvugt) wrote :

In theory, yes parallel packages libmirclient8 and libmirclient9 are "compatible" in that they don't conflict with each other and either will work for those packages linked to them. Both should speak the same protocol to the same server in the end.

In practice Mir had a rare protocol compatibility break (LP: #1486496) in Mir 0.15 that might break the older packages ability to function correctly. Not sure.

Daniel van Vugt (vanvugt) wrote :

xenial now contains only ubuntu-application-api3-touch, which uses the newer libmirclient9.

Changed in platform-api:
status: New → Fix Released
Changed in platform-api (Ubuntu):
status: New → Fix Released
Daniel van Vugt (vanvugt) wrote :

Also xenial touch images (devel-proposed) seem fine. Haven't checked rc-proposed or whatever the equivalent is.

Daniel van Vugt (vanvugt) wrote :

Confirmed the bug still exists in rc-proposed (313), but it is fixed in devel-proposed.

In rc-proposed 313 the issue still appears to be the old ubuntu-application-api2-touch, which depends on libmirclient8 causing this problem.

This is concerning because in recent months we've found a couple of incompatibilities between libmirclient8 and newer server releases so in theory anything actually using ubuntu-application-api2-touch could be quite broken right now.

summary: - rc-proposed contains three versions of Mir: 0.16.0 + 0.14.1 + 0.13.3
+ rc-proposed contains three versions of Mir: 0.17.1 + 0.14.1 + 0.13.3
Changed in canonical-devices-system-image:
milestone: none → ww02-2016
Pat McGowan (pat-mcgowan) wrote :

ubuntu-application-api2-touch was removed from the meta package on July 2 so not clear why it is still in the image as nothing depends on it.

Pat McGowan (pat-mcgowan) wrote :

ubuntu-touch depends on ubuntu-application-api2-examples depends on ubuntu-application-api2-touch

Pat McGowan (pat-mcgowan) wrote :

sil is fixing the seeds now

Changed in canonical-devices-system-image:
assignee: kevin gunn (kgunn72) → Pat McGowan (pat-mcgowan)
status: Confirmed → In Progress

It is fixed on latest rc-proposed (krillin 228)

phablet@ubuntu-phablet:~$ dpkg -l | grep libmir| awk '/^ii/ {print $2, $3}'

libmirclient-debug-extension1:armhf 0.18.0+15.04.20151216.1-0ubuntu1
libmirclient9:armhf 0.18.0+15.04.20151216.1-0ubuntu1
libmircommon5:armhf 0.18.0+15.04.20151216.1-0ubuntu1
libmircookie1:armhf 0.18.0+15.04.20151216.1-0ubuntu1
libmirplatform11:armhf 0.18.0+15.04.20151216.1-0ubuntu1
libmirprotobuf3:armhf 0.18.0+15.04.20151216.1-0ubuntu1
libmirserver36:armhf 0.18.0+15.04.20151216.1-0ubuntu1

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

I've found a way to reintroduce a similar problem on OTA-9 stable:

apt-get install mir-demos

And the resulting package installed is from Mir 0.19.0, while Unity8 and co are Mir 0.18.1 so they refuse to talk to each other.

Then again apt-anything on a phone is probably prone to such errors.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers