[System settings] VPN configuration not possible

Bug #1495553 reported by Jonas G. Drange on 2015-09-14
72
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
indicator-network (Ubuntu)
Undecided
Matthew Paul Thomas
ubuntu-system-settings (Ubuntu)
High
Jonas G. Drange

Bug Description

Reproduce:
Try configuring VPN

What happens:
You can't.

What should happen:
You should be able to.

Current specification: https://wiki.ubuntu.com/Networking#VPNs

Related branches

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → High
assignee: nobody → Matthew Paul Thomas (mpt)
summary: - VPN configuration not possible
+ [System settings] VPN configuration not possible
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in indicator-network (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed

Highly, highly, highly wanted!

no longer affects: ubuntu-ux
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
Pat McGowan (pat-mcgowan) wrote :

target ota9

Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → ww02-2016
status: New → In Progress
Bill Filler (bfiller) on 2015-12-01
Changed in canonical-devices-system-image:
milestone: ww02-2016 → backlog
Matthew Paul Thomas (mpt) wrote :
Changed in ubuntu-system-settings (Ubuntu):
assignee: Matthew Paul Thomas (mpt) → nobody
status: In Progress → Triaged
Changed in indicator-network (Ubuntu):
assignee: nobody → Matthew Paul Thomas (mpt)
Oliver Grawert (ogra) wrote :

on a sidenote, openvpn is preinstalled since forever on the image, if you store the config in the users home you can easily use it via the terminal app and user startup scripts. so all backend bits are already available, only the UI connection is missing.

Matthew Exon (ubuntubugs-mexon) wrote :

Openvpn is blocked in China. The protocol itself is detected and automatically blocked. So this isn't a solution for me, although I'm sure it's good enough for lots of people. PPTP and L2TP are allowed, presumably because they tend to be used by companies rather than individuals.

Changed in canonical-devices-system-image:
milestone: backlog → ww08-2016
Matthew Exon (ubuntubugs-mexon) wrote :

Looking at the updated spec:

“Type:” should contain those VPN types currently implemented, currently “OpenVPN”, and eventually “L2TP” and “PPTP”. While only one is implemented, the menu should be present but disabled

Presumably then ww08-2016 will allow me to configure OpenVPN, but not PPTP and L2TP. Should I submit separate bugs for those? Because those are the ones I'm actually affected by.

Jean-Baptiste Lallement (jibel) wrote :

@Matthew, yes please file a bug to add support for L2TP and PPTP to the phone. This report is about the lack of UI to configure the VPN.

I added them as separate bugs, bug #1523946 for PPTP and bug #1523948 for L2TP. The implementation and user interface changes will be different in each case and the priority may well be different as well.

Jonas G. Drange (jonas-drange) wrote :

I have added bug #1535680 to deal with the problem of implementing the VPN Preview Dialog.

Please implement this. It's a highly desired feature.
Thank you, the team is doing an awesome job! Ubuntu mobile is getting better and better by the day.

Changed in ubuntu-system-settings (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Jonas G. Drange (jonas-drange)
Jonas G. Drange (jonas-drange) wrote :

The first phase will land with some functionality held back:

* Bug 1546560: will not be able to set a certificate password.
* Bug 1546559: causes discrepancies between the desired design and the implementation, namely the OK/Cancel pattern won't work. Instead, only an OK button will be implemented.
* Bug 1546573: can't set routing configuration on vpn connections.

Jonas G. Drange (jonas-drange) wrote :

All the bugs mentioned in #13 have been fixed and will not hold back functionality (except the route editor).

Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+16.04.20160314.4-0ubuntu1

---------------
ubuntu-system-settings (0.3+16.04.20160314.4-0ubuntu1) xenial; urgency=medium

  [ jonas-drange ]
  * New VPN panel with happy path test (LP: #1495553)

 -- <email address hidden> (Jonas G. Drange) Mon, 14 Mar 2016 21:26:48 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers