[UbuntuShape] Rendering is aliased sometimes since the Shell implements the orientation

Bug #1466656 reported by Alan Pope 🍺🐧🐱 🦄 on 2015-06-18
80
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
High
Loïc Molinari

Bug Description

$ adb shell system-image-cli --info
current build number: 23
device name: krillin
channel: ubuntu-touch/stable/bq-aquaris.en
last update: 2015-06-15 19:22:22
version version: 23
version ubuntu: 20150611.3
version device: 20150529-8e13c5f
version custom: 20150528-722-29-15-vivid

Steps to reproduce:-

1. Swipe down indicators
2. Rotation
3. Switch rotation lock _off_, that is "X"
4. Hold phone in portrait and navigate to the top of the apps scope

Observe normal icons

5. Rotate phone 90 degrees to landscape, pull the scope "down" (to the side) slightly to force a re-draw

Observe poor anti-aliasing around the ubuntu shapes.

Two screenshots attached.
device-2015-06-18-220419.png - portait
device-2015-06-18-220428.png - landscape

The effect is most noticable if you open both of the attachments full-size and switch between them.

Related branches

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Szymon Waliczek (majster-pl) wrote :

The same problem on Meizu mx4 r1

This screenshot was took after my 1st boot on OTA-4

Launchers icon look having the same effect of this bug. You will note that screen rotation is locked (Not sure it is same bug then cancel screenlock "rule" or if it's another bug with same behavior)

Neil McPhail (njmcphail) wrote :

I have found a similar rendering bug which may be the same problem, running OTA5 on krillin:

- Open browser in portrait mode
- rotate to landscape then back to portrait
- The "location" text field outline will become corrupted as per the attached screenshot.

Michal Predotka (mpredotka) wrote :

 Also other Ubuntu shaped text entries suffer from this problem.

Changed in canonical-devices-system-image:
status: New → Confirmed
milestone: none → ww34-2015
Tim Peeters (tpeeters) wrote :
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Loïc Molinari (loic.molinari)
Michal Predotka (mpredotka) wrote :

Screenshot with the problem visible on a button and progress bar.

Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High
summary: - Rotated ubuntu shapes have poor anti-aliasing
+ [UbuntuShape] Rendering is aliased sometimes since the Shell implements
+ the orientation
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1603+15.10.20150812-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1603+15.10.20150812-0ubuntu1) wily; urgency=medium

  [ Tim Peeters ]
  * Use grid units in Icons in the showcase gallery. Fixes LP: #1481489
  * Disable header buttons when the header is animating. Fixes LP: #1478147
  * Add ActionBar examples to the gallery.
  * Make the default MainView background plain white. Fixes LP: #1481834

  [ Zsombor Egri ]
  * Fixing swiping over active components. Fixes LP: #1479688.
  * Fixing broken BottomEdgeHint gallery page.

  [ Zoltán Balogh ]
  * Fix packaging question marks / issues. Fixes LP: #1481584

  [ Loïc Molinari ]
  * UbuntuShape - Added support drop shadow aspect support to UbuntuShapeOverlay
    Fixes LP: #1480197.
  * UbuntuShape - Removed content orientation work around.
    The shape was using a workaround to make it render correctly when the
    content orientation was not the native one. This was perfect for the
    OrientationHelper shipped with the toolkit but now that the Shell
    implements the rotation, this is not needed anymore and causes some
    rendering issues. Note that the shape will still needs to support
    correct rendering when rotated using the rotation property of the Item,
    but that is a different issue. Fixes LP: #1466656.
  * UbuntuShape - Added a DropShadow aspect. Fixes LP: #1478129.
  * Renamed ShellIcon to ProportionalShape.
  * UbuntuShape - Added an ShellIcon item. Fixes LP: #1478130

  [ Nick Dedekind ]
  * Added LiveTimer.

  [ Christian Dywan ]
  * Grab focus when Dialog is shown.
  * Set Qt.IBeamCursor on text component MouseArea's. Fixes LP: #1483823
  * Make automaticOrientation on MainView a no-op. Fixes LP: #1470258
  * Fix warnings on undefine theme.name in gallery
    examples/ubuntu-ui-toolkit-gallery/ubuntu-ui-toolkit-gallery.qml:48:
      TypeError: Cannot read property of null.

  [ Ken VanDine ]
  * Don't fail if MainView doesn't have a useDeprecatedToolbar property
    Fixes LP: #1451243

  [ CI Train Bot ]
  * Resync trunk. added: examples/ubuntu-ui-toolkit-gallery/po/uk.po

 -- CI Train Bot <email address hidden> Wed, 12 Aug 2015 17:31:20 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Zoltan Balogh (bzoltan) on 2015-08-18
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers