Remove GTK3 from phone images

Bug #1436211 reported by Timo Jyrinki on 2015-03-25
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
address-book-service (Ubuntu)
Undecided
Unassigned
evolution-data-server (Debian)
New
Unknown
evolution-data-server (Ubuntu)
High
Unassigned
gnome-control-center-signon (Ubuntu)
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Undecided
Unassigned
ubuntu-touch-meta (Ubuntu)
Undecided
Unassigned
unity-asset-pool (Ubuntu)
Undecided
Unassigned

Bug Description

This is a wishlist bug to eventually remove GTK3 from Ubuntu Phone images to save some space.

===TODO===

-- address-book-service --

address-book-service depends on evolution-data-server, which depends on GTK3. evolution-data-server further depends on libgweather-3-6 and libgcr-ui-3-1 which both directly depend on GTK3 too.

Would it be possible to work with libfolks-eds25 and other libraries alone? Or would it be possible to modify evolution-data-server building to not depend on GTK3 since we're not using the toolkit anyway?

-- themes (unity-asset-pool, adwaita-icon-theme...) --

humanity-icon-theme, ubuntu-mono and unity-asset-pool depend on adwaita-icon-theme. adwaita-icon-theme directly depends on GTK3.

-- ubuntu-system-settings --

ubuntu-system-settings depends on libtimezonemap1 which directly depends on GTK3. Maybe the library could be made not to depend on GTK3?

===DONE===
-- gnome-control-center-signon --
Since libaccount-plugin-1.0-0 is included on Ubuntu Phone images, would it be possible to refactor it so that it would not depend on GTK3 bringing it on the images?

description: updated
Changed in ubuntu-touch-meta (Ubuntu):
status: New → Invalid
description: updated
description: updated
Timo Jyrinki (timo-jyrinki) wrote :

libaccount-plugin-1.0-0 removed from images with add_package in livecd-rootfs live-build config to explicitly pull ubuntu-system-settings-online-accounts instead of the first mentioned libaccount-plugin-google in a "|" dependency: http://people.canonical.com/~ogra/touch-image-stats/149.changes

Changed in gnome-control-center-signon (Ubuntu):
status: New → Fix Released
Changed in canonical-devices-system-image:
assignee: nobody → Pat McGowan (pat-mcgowan)
importance: Undecided → High
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: none → ww21-2015
Changed in evolution-data-server (Ubuntu):
status: New → In Progress
importance: Undecided → High
Changed in evolution-data-server (Debian):
status: Unknown → New
Timo Jyrinki (timo-jyrinki) wrote :

As a related item, GTK2 was successfully dropped starting at http://people.canonical.com/~ogra/touch-image-stats/20150521.changes

Changed in canonical-devices-system-image:
milestone: ww21-2015 → ww28-2015
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-service (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Changed in unity-asset-pool (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: ww28-2015 → ww34-2015
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
description: updated
Lars Karlitski (larsu) wrote :

litimezonemap contains gtk3 widgets that are used in unity7's system settings. Can we make unity-system-settings not depend on it?

Changed in canonical-devices-system-image:
milestone: ww40-2015 → ww46-2015
Pat McGowan (pat-mcgowan) wrote :

@timo can you update the status for this

Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → Timo Jyrinki (timo-jyrinki)
Timo Jyrinki (timo-jyrinki) wrote :

@Pat: We'd need desktop team to do the splitting they've been thinking about. seb128 was talking about the evolution-data-server, thinking it's doable.

Maybe Ken could look at the ubuntu-system-settings libtimezonemap dependency larsu mentioned in comment #6.

After that there'd be the theme/artwork packages which could also fall into desktop team's hands, thinking about how to relax the dependencies or split packages so that they'd be usable on Touch without bringing GTK dependencies.

Timo Jyrinki (timo-jyrinki) wrote :

I think this might be best assigned to Bill first, possibly to Will later for the desktop splitting parts.

Changed in evolution-data-server (Ubuntu):
assignee: nobody → Sebastien Bacher (seb128)
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in canonical-devices-system-image:
assignee: Timo Jyrinki (timo-jyrinki) → Bill Filler (bfiller)
Changed in canonical-devices-system-image:
milestone: ww46-2015 → ww02-2016
Bill Filler (bfiller) on 2015-12-15
Changed in canonical-devices-system-image:
milestone: ww02-2016 → backlog
Charles Kerr (charlesk) wrote :

From cursory grepping, it looks like evolution-data-server's direct use of gtk+ is limited to (a) generating documentation with gtk-doc and (b) loading gtk modules when running tests with the environment variable 'EDS_TESTING' set.

libgweather's got a harder dependency on gtk, but evolution-data-server's use of libgweather is optional and can be turned off in its configure script with --disable-gtk, which also disables its use of gcr

Changed in evolution-data-server (Ubuntu):
assignee: Sebastien Bacher (seb128) → nobody
Changed in ubuntu-system-settings (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.