greeter does not properly update infographic after unlock

Bug #1378814 reported by Bill Filler on 2014-10-08
38
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Band-aids for Ubuntu Phone
Undecided
Tomás Tormo
Canonical System Image
High
Michał Sawicz
unity8 (Ubuntu)
High
Tomás Tormo

Bug Description

This bug has been here since forever, but really needs to get cleaned up for rtm.

Steps to reproduce:
- send 2 text messages
- lock your phone
- unlock your phone
- confirm infographic says "2 text messages sent today"
- lock your phone for the night and go to sleep
- unlock your phone the next day

Expected results:
- infographic should be cleared, or show relevant information for today

Actual results:
- infographic still says "2 text messages sent today"

When the phone is unlocked the greeter should update the infographic text

Related branches

Bill Filler (bfiller) wrote :

consider marking this critical so it gets fixed for rtm as it's a very visible thing the user will see from day 1

tags: added: rtm14
Joe Odukoya (jodukoya) wrote :

Please make this High.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-greeter (Ubuntu):
status: New → Confirmed
Julia Palandri (julia-palandri) wrote :

This still happens after ota4

John McAleely (john.mcaleely) wrote :

One particular frustration for our user group is that this seems to reveal 'stale translations', so if you change your language, I understand that the strings can appear in the 'old' language.

Changed in canonical-devices-system-image:
importance: Undecided → High
assignee: nobody → Pat McGowan (pat-mcgowan)
John McAleely (john.mcaleely) wrote :

@Pat, where does this belong?

Ruud (ruud800) on 2015-07-09
Changed in canonical-devices-system-image:
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

The original bug report is to me not high priority as a double tap updates the infographic. We should however add logic to update on re-display.

The other issue is that the text displayed is really data and not part of the active UI which is subject to dynamic translation. I do not think we will fix that as changing languages would seem to be something one does once.

Changed in band-aids-uphone:
assignee: nobody → Tomás Tormo (tomas-tormo)
status: New → In Progress
no longer affects: unity-greeter (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2016-11-09
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Tomás Tormo (tomas-tormo)
Changed in canonical-devices-system-image:
assignee: Pat McGowan (pat-mcgowan) → Michał Sawicz (saviq)
milestone: none → 14
Michał Sawicz (saviq) on 2016-11-10
Changed in canonical-devices-system-image:
milestone: 14 → backlog
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.14+17.04.20161109-0ubuntu1

---------------
unity8 (8.14+17.04.20161109-0ubuntu1) zesty; urgency=medium

  [ Albert Astals Cid ]
  * Make more CardTool properties readonly
  * Make the > in Dash Section Header be after text (LP: #1508905)
  * Rework Dash Preview column margins
  * Improve LVWPH <-> GenericScopeView interaction (LP: #1508905,
    #1622423)
  * Make the PreviewButtons be of the width of the button and not half
    the total width
  * Fix first column of the preview table to be 25%

  [ Andrea Cimitan ]
  * Remove background under header pagination dots, update dots assets,
    remove dash paper background, update bottom edge asset
  * Few styling changes for cards
  * various tweaks to fonts inside previews
  * More visual tweaks

  [ Brian Douglass ]
  * Add a new setting to enable/disable the launcher

  [ Lukáš Tinkl ]
  * Stabilize test_doubleTapToMaximizeWindow()
  * Enable loading the main Qt catalog which in turn allows for using
    RTL languages
  * Fix the pixelated notification icon by setting sourceSize (LP:
    #1637712)

  [ Michael Terry ]
  * More path lookup fixes for running inside of a snap. (LP: #1629009)

  [ Michael Zanetti ]
  * Added blur and darkening to wallpaper while in spread
  * Fixes in the spread after design review (LP: #1637502, #1638848)
  * More fixes to the unified stages code (LP: #1637205, #1637249,
    #1637258)
  * Delay alt tab for tiny bit in order to avoid flickering on quick alt-
    tabs

  [ Tomás Tormo ]
  * Reload Infographics userdata when the day changes (LP: #1378814)

 -- Michał Sawicz <email address hidden> Wed, 09 Nov 2016 15:10:32 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers