Stop and restart the camera automatically when app changes active state

Bug #1375163 reported by Ugo Riboni on 2014-09-29
44
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
qtubuntu-camera (Ubuntu)
Undecided
Florian Boucault

Bug Description

At the moment when an application that started the camera stops becoming active, the camera remains running and other applications can't use it.

The system should automatically detect when an app is being deactivate and stop the camera, as a minimum.

To be symmetric, when the app gets activated again, it should also restart it. However this might not be as simple since the camera might have been re-configured by other apps so if we want the process to be full automatic the state of the camera configuration should be saved and restored as well.

Related branches

Michael Zanetti (mzanetti) wrote :

This can be reproduced by opening uTorch, leaving it open and then open the camera-app. The camera app will be broken.

Gerry Boland (gerboland) wrote :

Is there any reason the camera could not work in multiple applications simultaneously?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in qtubuntu-camera (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
milestone: none → backlog
status: New → Confirmed
Changed in qtubuntu-camera (Ubuntu):
assignee: nobody → Florian Boucault (fboucault)
Changed in qtubuntu-camera (Ubuntu):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in qtubuntu-camera (Ubuntu):
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in qtubuntu-camera (Ubuntu):
status: Fix Committed → Fix Released
Buzea Bogdan (bogdanke8) wrote :

Why is this bug on backlog if this is released?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers