Calendar icon usually shows the wrong date

Bug #1362962 reported by Matthew Paul Thomas on 2014-08-29
136
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Ubuntu Calendar App
Wishlist
Unassigned
Ubuntu UX
Wishlist
Paty Davila
indicator-datetime (Ubuntu)
High
Renato Araujo Oliveira Filho
ubuntu-themes (Ubuntu)
High
Matthieu James
unity-scope-click (Ubuntu)
Wishlist
Unassigned

Bug Description

Problem occurs with: Ubuntu 14.10 r203
Does not occur with: iOS, Windows Phone

1. In the clock menu, find the calendar app and launch it.
2. In the Launcher or Dash, find the Calendar app.

What you see:
1. The icon always says "25", regardless of the actual date.
2. The icon always says "28", regardless of the actual date.

What you should see:
1. The icon shows the current date.
2. The icon shows the current date.

The equivalent for PC is bug 1362033, and for the Clock app is bug 1362964.

This depends on bug 1453795 for Unity letting an app change its own icon.

Related branches

description: updated
Mihir Soni (mihirsoni) wrote :

Matthew, thanks for the bug report, but icon is an image.

As an icon , i believe it shouldn't change frequently.

Added ubuntu-ux. Are we expecting the platform to get modifiable / animate-able icons?

Changed in ubuntu-calendar-app:
status: New → Confirmed
Mihir Soni (mihirsoni) on 2014-08-29
Changed in ubuntu-calendar-app:
importance: Undecided → Wishlist
Matthew Paul Thomas (mpt) wrote :

Mihir, that it's an image doesn't matter. It's an image on iOS, OS X, and Windows Phone too, but they don't have the problem.

description: updated
Kunal Parmar (pkunal-parmar) wrote :

yes, on many platform ICON changes date as per current date, thought for this issue we need support from platform. Not sure what calendar can do.

no longer affects: ubuntu-ux
Felix Wilke (felixw83) wrote :

I think the current behavior is misleading. The Indicator is supposed to list the dates of the next events. Today is the 20th. A quick look at my events leads me to the wrong conclusion, that my next three events are on 25th - even though they are on Wednesday (!the only shown information!) which is the 22nd.

If it is not recommended to change the icon to the respective date, an icon with no actual number should be used.

Matthew Paul Thomas (mpt) wrote :

(Added unity8 since this requires either special-casing the Calendar, or an API for an app to change its own icon.)

no longer affects: unity8 (Ubuntu)
description: updated
Charles Kerr (charlesk) on 2015-06-02
Changed in indicator-datetime (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Johannes Kempf (johanneskempf) wrote :

As a workaround I would suggest to implement felixw83's proposal: Use a neutral picture without a number for indicator and app-icon as long as an automatically change of icon can't be implemented.
The "25" and "28" are very irritating and misleading.

Johannes Kempf (johanneskempf) wrote :

At least the network-indicators are able to change its icons. The signal-strength is visualized via the icon itself.

Changed in unity-scope-click (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Johannes Kempf (johanneskempf) wrote :

At least the telegram app is able to indicate the number of unread messages within its icon.
Why not using this visualization method to indicate the current day's number?

Bill Filler (bfiller) wrote :

@renato
Please change the icon used in the indicator to use generic calendar icon that doesn't have a date as this is confusing (per design, comment https://bugs.launchpad.net/ubuntu-calendar-app/+bug/1362962/comments/7)

Changed in ubuntu-calendar-app:
status: Confirmed → Invalid
Changed in indicator-datetime (Ubuntu):
importance: Wishlist → High
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
Charles Kerr (charlesk) wrote :

indicator-datetime is already using the generic calendar icon from ubuntu-mobile/actions/scalable/calendar.svg, which has the '25' in it.

IMO the issue is that the icon should be tweaked to remove the '25'

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Matthieu James (tiheum)

My sugestion is to use the appointment icon that does not contain any number.

Michal Predotka (mpredotka) wrote :

Symbolic icon proposition in attachment.

Bill Filler (bfiller) on 2016-04-14
Changed in canonical-devices-system-image:
milestone: none → 11
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
status: New → Confirmed

@Matthieu, could you replace the theme icon with the new one?

Bill Filler (bfiller) on 2016-04-22
tags: added: system-apps-11
Matthieu James (tiheum) wrote :

I will update the theme today with a new generic calendar mono icon (for the indicator).
We are not planning to change the calendar app icon (or to make dynamic) at the moment.

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → In Progress
Matthieu James (tiheum) on 2016-04-26
Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Charles Kerr (charlesk) wrote :

tiheum, \o/

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Matthieu James (tiheum) on 2016-05-09
Changed in ubuntu-themes (Ubuntu):
status: Fix Committed → Fix Released
Ryan Prior (ryanprior) wrote :

This should be closed as "won't fix," marking it as "released" is misleading.

Pat McGowan (pat-mcgowan) wrote :

Reopening since the calendar app icon is still unchanged

Changed in canonical-devices-system-image:
milestone: 11 → 12
status: Fix Committed → In Progress
Bill Filler (bfiller) wrote :

@design
We just need an updated application icon for the calendar app that doesn't use a number (i.e. 28)

Changed in ubuntu-ux:
importance: Undecided → High
Pat McGowan (pat-mcgowan) wrote :

based on this comment
We are not planning to change the calendar app icon (or to make dynamic) at the moment.

This bug is still open

Changed in ubuntu-themes (Ubuntu):
status: Fix Released → Confirmed
Changed in canonical-devices-system-image:
milestone: 12 → 13
Pat McGowan (pat-mcgowan) wrote :

The action icon was updated but not the app icons

Paty Davila (dizzypaty) on 2016-08-26
Changed in ubuntu-ux:
assignee: nobody → Paty Davila (dizzypaty)
importance: High → Wishlist
Paty Davila (dizzypaty) on 2016-08-26
Changed in ubuntu-ux:
status: New → Triaged
Changed in canonical-devices-system-image:
milestone: 13 → backlog
tags: added: ubuntu-touch
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers