Art in cards with backgrounds are Ubuntu-shaped

Bug #1330959 reported by Michał Sawicz on 2014-06-17
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
Ubuntu UX
High
Alex Milazzo
ubuntu-ui-toolkit (Ubuntu)
High
Loïc Molinari
unity8 (Ubuntu)
High
Andrea Cimitan
unity8 (Ubuntu RTM)
High
Andrea Cimitan

Bug Description

When a card has its background enabled, the art should not have its bottom edge shaped.

Until the new shape item comes, we should probably use the UbuntuShapeForItem component.

---------------------

Desired resolution:

This is part of a bigger redesign project (Scopes toolkit) and it can't be fixed as a single bug. The description and specs will be updated as soon as they are available.

Michał Sawicz (saviq) wrote :
Michał Sawicz (saviq) on 2014-06-17
Changed in unity8:
assignee: Albert Astals Cid (aacid) → Michał Sawicz (saviq)
Thomas Strehl (strehl-t) on 2014-07-29
tags: added: rtm14
kevin gunn (kgunn72) wrote :

new Ubuntushape out on Aug5, is this bug still valid ?
marking as invalid, please change if i'm wrong

Changed in unity8:
status: Triaged → Invalid
Michał Sawicz (saviq) wrote :

Yeah, still valid, new shape not new enough...

Changed in unity8:
status: Invalid → Triaged
Michał Sawicz (saviq) on 2014-09-03
Changed in unity8 (Ubuntu):
assignee: nobody → Michał Sawicz (saviq)
importance: Undecided → High
status: New → Triaged
kevin gunn (kgunn72) on 2014-09-08
no longer affects: unity8
tags: added: touch-2014-10-02
kevin gunn (kgunn72) on 2014-09-16
tags: added: touch-2014-10-30
removed: touch-2014-10-02
tags: added: ota-1
removed: touch-2014-10-30
kevin gunn (kgunn72) on 2014-11-21
Changed in unity8 (Ubuntu RTM):
assignee: nobody → Michał Sawicz (saviq)
status: New → Triaged
importance: Undecided → High
Michał Sawicz (saviq) wrote :

This depends on bug #1157712 and/or #1157712.

Michał Sawicz (saviq) wrote :

Erm... yeah, you know what I mean :P

Olli Ries (ories) on 2014-11-26
Changed in canonical-devices-system-image:
assignee: nobody → Canonical Devices Products (canonical-devices-products-team)
importance: Undecided → High
milestone: none → r1
status: New → Confirmed
Michał Sawicz (saviq) wrote :

I'm not sure we'll be able to fix this by r1, the related bug #1157712 in UITK was just closed 'Won't Fix', and any workaround we employ will negatively impact performance of items in the dash suffering from this.

Michał Sawicz (saviq) on 2014-12-05
Changed in unity8 (Ubuntu):
assignee: Michał Sawicz (saviq) → nobody
Changed in unity8 (Ubuntu RTM):
assignee: Michał Sawicz (saviq) → nobody
Michał Sawicz (saviq) on 2014-12-05
Changed in unity8 (Ubuntu RTM):
status: Triaged → New
Michał Sawicz (saviq) on 2014-12-05
Changed in canonical-devices-system-image:
status: Confirmed → New
Pat McGowan (pat-mcgowan) wrote :

confirmed status in system-image means product team approved it, it is not related to subtask status

Changed in canonical-devices-system-image:
status: New → Confirmed
Michał Sawicz (saviq) wrote :

Yeah, but it's targeted to ww51, which is not achievable for this bug. I though that setting to New is meant to have the product team reevaluate.

Pat McGowan (pat-mcgowan) wrote :

Bug #1396170 seems to have what is required, will target both that bug and this one to next milestone.

Changed in canonical-devices-system-image:
milestone: ww51-2014 → ww03-2015
kevin gunn (kgunn72) wrote :

so looking at bug #1396170, the branch associated with it is just now being reviewed, and we're in ww02. loic said likely to land within the month, but i'd propose to move this unity8 bug out to ww05 at least, and likely ww07 would be more real

Changed in canonical-devices-system-image:
status: Confirmed → New
Changed in canonical-devices-system-image:
status: New → Confirmed
milestone: ww03-2015 → ww05-2015
Zsombor Egri (zsombi) wrote :

Kevin, Pat, the UITK fix [1] wasn't planned for RTM (UITK v1.1) but for Vivid (UITK 1.2) as it introduces a brand new component. The fix is based on a major UbuntuShape refactoring [2], and needs smoke tested.

However, we can redirect both MPs to land in UITK 1.1, RTM in case this is so urgent. It's a bit risky, but if the house is burning, we can live with that.

[1] https://code.launchpad.net/~loic.molinari/ubuntu-ui-toolkit/ubuntu-ui-toolkit-shape-overlay/+merge/243324
[2] https://code.launchpad.net/~loic.molinari/ubuntu-ui-toolkit/ubuntu-ui-toolkit-shape-rewrite/+merge/242791

Changed in canonical-devices-system-image:
milestone: ww05-2015 → ww07-2015
Changed in canonical-devices-system-image:
milestone: ww07-2015 → ww11-2015
Pat McGowan (pat-mcgowan) wrote :

The UITK fi is in staging and will land soonish

Changed in canonical-devices-system-image:
assignee: Canonical Devices Products (canonical-devices-products-team) → Kevin Gunn (kgunn)
milestone: ww11-2015 → ww13-2015
kevin gunn (kgunn72) on 2015-03-12
Changed in canonical-devices-system-image:
assignee: Kevin Gunn (kgunn) → kevin gunn (kgunn72)
Andrea Cimitan (cimi) on 2015-03-16
Changed in unity8 (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
Changed in unity8 (Ubuntu RTM):
assignee: nobody → Andrea Cimitan (cimi)
Changed in canonical-devices-system-image:
milestone: ww13-2015 → ww17-2015
Andrea Cimitan (cimi) on 2015-04-15
Changed in unity8 (Ubuntu):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
milestone: ww17-2015 → ww21-2015
kevin gunn (kgunn72) on 2015-05-15
Changed in canonical-devices-system-image:
milestone: ww21-2015 → ww24-2015
Pat McGowan (pat-mcgowan) wrote :

pushing again, no idea how to see this in the product

Changed in canonical-devices-system-image:
milestone: ww24-2015 → ww34-2015
Andrea Cimitan (cimi) wrote :

@pat: it's blocked on some UITK work

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Zsombor Egri (zsombi)
Andrea Cimitan (cimi) wrote :

we need the new shadows of the new ubuntushape to land, then we start migrating to it

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Zsombor Egri (zsombi) → nobody
assignee: nobody → Loïc Molinari (loic.molinari)
Changed in unity8 (Ubuntu):
status: In Progress → New
Zsombor Egri (zsombi) on 2015-07-14
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Triaged
importance: Undecided → High
Andrea Cimitan (cimi) on 2015-07-21
Changed in unity8 (Ubuntu):
status: New → In Progress
kevin gunn (kgunn72) wrote :

for clarity. This would need sdk1.3

kevin gunn (kgunn72) on 2015-07-23
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Andrea Cimitan (cimi) on 2015-07-28
Changed in unity8 (Ubuntu RTM):
status: New → Incomplete
kevin gunn (kgunn72) on 2015-07-28
Changed in unity8 (Ubuntu):
status: In Progress → Incomplete
Changed in canonical-devices-system-image:
assignee: kevin gunn (kgunn72) → Pat McGowan (pat-mcgowan)
Andrea Cimitan (cimi) on 2015-07-31
Changed in unity8 (Ubuntu):
status: Incomplete → In Progress
status: In Progress → Incomplete
Andrea Cimitan (cimi) wrote :

Is the art supposed to have a shape around it (like now, but with squared bottom edge) or be completely flat and with squared bottom edge?

Changed in canonical-devices-system-image:
status: In Progress → Confirmed
assignee: Pat McGowan (pat-mcgowan) → Zoltan Balogh (bzoltan)
Changed in ubuntu-ux:
assignee: nobody → Alex Milazzo (digitalalex)
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-ux:
status: Triaged → In Progress
description: updated
Bill Filler (bfiller) on 2015-08-19
Changed in canonical-devices-system-image:
milestone: ww34-2015 → ww40-2015
Changed in canonical-devices-system-image:
status: Confirmed → Incomplete
milestone: ww40-2015 → backlog
Alex Milazzo (digitalalex) wrote :

Will be closing this bug since the desired solution won't match the bug issue. This bug relates to the entire update of the scope toolkit that will be publishing shortly.

Changed in ubuntu-ux:
status: In Progress → Won't Fix
Albert Astals Cid (aacid) wrote :

Following ubuntu-ux decision in unity8 side

Changed in unity8 (Ubuntu):
status: Incomplete → Won't Fix
Changed in unity8 (Ubuntu RTM):
status: Incomplete → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers