Panel._drag_to_open helper drags too quickly, drag not registered

Bug #1520171 reported by Brendan Donegan on 2015-11-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
camera-app
Fix Released
High
Brendan Donegan

Bug Description

The camera-app Autopilot helper _drag_to_open has the drag rate set to sys.maxint. This very fast drag is not being registered. Using the default drag rate works fine so we should remove the setting of the drag rate to sys.maxint.

current build number: 187
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2015-11-24 09:51:16
version version: 187
version ubuntu: 20151124
version device: 20151028-869191d
version custom: 20151111--36-46-vivid

Related branches

Florian Boucault (fboucault) wrote :

Some AP tests fail as a consequence, for example: camera_app.tests.test_options.TestCameraOptions.test_toggle_grid_lines

Changed in camera-app:
status: New → In Progress
importance: Undecided → High
Changed in canonical-devices-system-image:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww02-2016
Bill Filler (bfiller) on 2015-12-01
Changed in camera-app:
assignee: nobody → Brendan Donegan (brendan-donegan)
Changed in camera-app:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers