When a file can't be thumnailed the photo grid keeps loosing its images and hitting timeouts

Bug #1389678 reported by Sebastien Bacher
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Unassigned
camera-app
Fix Released
High
Florian Boucault
thumbnailer (Ubuntu)
Undecided
Unassigned
thumbnailer (Ubuntu RTM)
Undecided
Unassigned

Bug Description

Using rtm 142 on krillin, the photo roll previews are missing for most part (the log indicates timeouts from the thumbnailer).

Even when they are displayed, scrolling in the view is enough to get the image replaced by empty squares (that might be a slightly different issue, let me know if you prefer a different report about it)

Note that the gallery app doesn't have that issue, so even if the thumbnailer is slow the camera handling of the timeout seems less optimal than the gallery one

There is also the fact that the roll view doesn't display spinners while loading, which gallery does

Related branches

Revision history for this message
Sebastien Bacher (seb128) wrote :

Ok, in fact that seems to be happening when a file confuses the thumbnailer.
It's easy to get by doing a 1s video (basically switch the camera in video recording, press record and directly stop, the resulting file seems to be enough to create the confusion)

summary: - The photo roll previews are not correctly displayed
+ When a file can't be thumnailed the photo grid keeps loosing its image
+ and hitting timeouts
summary: - When a file can't be thumnailed the photo grid keeps loosing its image
+ When a file can't be thumnailed the photo grid keeps loosing its images
and hitting timeouts
Changed in camera-app:
importance: Undecided → High
status: New → Confirmed
Changed in camera-app:
assignee: nobody → Arthur Mello (artmello)
Revision history for this message
Arthur Mello (artmello) wrote :

We have this same problem with gallery-app. It seems to be related with the use of Ubuntu.Thumbnailer. Here is the bug opened against it with more information:

https://bugs.launchpad.net/thumbnailer/+bug/1391286

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package thumbnailer - 1.3+15.04.20150122-0ubuntu1

---------------
thumbnailer (1.3+15.04.20150122-0ubuntu1) vivid; urgency=low

  [ Florian Boucault ]
  * Keeps track of failed thumbnails and do not try to regenerate them.
    (LP: #1389678)
  * QML thumbnail provider: make sure sourceSize (aka requestedSize) is
    respected by downscaling at loading time if necessary. Makes
    TN_SIZE_ORIGINAL case much faster. (LP: #1391368)
 -- Ubuntu daily release <email address hidden> Thu, 22 Jan 2015 08:56:16 +0000

Changed in thumbnailer (Ubuntu):
status: New → Fix Released
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww05-2015
status: New → In Progress
Changed in camera-app:
status: Confirmed → In Progress
assignee: Arthur Mello (artmello) → Florian Boucault (fboucault)
Changed in canonical-devices-system-image:
milestone: ww05-2015 → ww07-2015
Changed in thumbnailer (Ubuntu RTM):
status: New → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
Changed in camera-app:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers