Content Server does not correctly display custom field of type "rating"

Bug #938303 reported by Paul Arking on 2012-02-22
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

When adding a custom field of type "ratings, shown with stars", although it works properly within the main calibre program, the content server will show it with the data from the main "Rating" field.

So, for example, if Book X has a rating of 2 stars in the main "Rating" field, and a rating of 4 stars in the additional custom field called, for example, "My Rating", it will show the two different ratings in the two different columns properly within the Calibre program, but on the web site (content server), it will show "Rating: **" and "My Rating: **" .

I will attach screenshots to demonstrate this.

Related branches

Paul Arking (sq2d3bipy-paul) wrote :
Paul Arking (sq2d3bipy-paul) wrote :

Here's a screenshot of the config of the column, in case that's important.

Charles Haley (cbhaley) wrote :

Fix submitted

Changed in calibre:
status: New → Fix Committed

Fixed in branch lp:calibre. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released
Paul Arking (sq2d3bipy-paul) wrote :

Wow, that was incredibly fast. You guys are amazing!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers