calibre: e-book management

New comma-enabled author folder name can cause data loss

Reported by emerson on 2012-01-26
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

(Calibre 0.8.36 on Windows 7)

I was sifting through the results of a "Library Maintenance -> Check Library -> Check the files" and I noticed that I had an extra couple of formats (pdf and lit) in a book's folder:

    Martin_ George R.R_/A Dance With Dragons (5659)

...that the database didn't know about; it only had the epub and mobi formats listed.

Historically it's worked fine, in this situation, to drag a file from a book's folder onto the "edit" pane for the book to add it -- it just adds the format to the database and starts knowing the file is there.

This time, however, when I did that and then clicked 'OK' on the edit pane, I got a file-not-found style error. When I went to look, Calibre had created a new folder for the author and the book, with the author name now having a comma in it:

    Martin, George R.R_/A Dance With Dragons (5659)

...and moved the existing formats that it knew about into this folder. I'd seen in the changelog recently that it was going to start doing that, so that part didn't surprise me.

Apparently, though, after moving the files that it knew about to the new folder, it -deleted- the old "Martin_.../A Dance..." folder, containing the pdf and lit files, then -afterwards- tried to add them into the database.

So they're gone. It's not a terrible loss but I might suggest that if calibre is going to re-save/move any edited book under a new author folder, it should drag along everything in the original folder whether it knows about it or not.

Thanks!

Related branches

Fixed in branch lp:calibre. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers