custom column acting incorrectly

Bug #763788 reported by Chad Schmidt on 2011-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

version: at least past 4-5 versions
os: Vista

summary: custom column type: Text column for keeping series-like information
when editing metadata for single book. choosing 'selection' from the drop down menu appends a comma to the selection. moving to another book and repeating this behavior shows that there is now 'selection' and 'selection,' (with a comma).

this behavior is NOT repeated if choosing "selection" when editing metadata for multiple books

Related branches

Kovid Goyal (kovid) on 2011-04-17
Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Charles Haley (cbhaley) wrote :

I cannot duplicate this.

The steps I take:
1) select a book with an empty value in the #series column
2) edit metadata. I see the dialog.
3) switch to the custom metadata tab.
4) press the down arrow for the #series box.
5) select one of the offered custom series names.

At this point there is no comma shown.

I also tried it on a book with a value in the #series column. Same result.

What are you doing different from the above?

Changed in calibre:
status: Triaged → Incomplete
Charles Haley (cbhaley) wrote :

OK, I found how to do it. You must type a prefix of the series, then select one of the offered completions.

Changed in calibre:
status: Incomplete → Confirmed
Charles Haley (cbhaley) on 2011-04-18
Changed in calibre:
status: Confirmed → Fix Committed

Fixed in branch lp:calibre. The fix will be in the next release. calibre is usually released every Friday.

 status fixreleased

Changed in calibre:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers