Epub files with non-functional bookmarks

Bug #2029521 reported by Chris Lott
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Fix Released

Bug Description

As requested, here is an epub file in which I have made bookmarks where the bookmarks aren't functional (do no lead to the associated place in the text). The location of the bookmarks should be obvious because the bookmarks are the titles of the individual poems/pieces in the book where I made the bookmark. Each was made by clicking the bookmark button on the poem or piece titled. I'm not sure how else to describe the location?


I am running Calibre 6.23 on OSX Ventura 13.4.1

Revision history for this message
Chris Lott (fncll) wrote :
description: updated
Revision history for this message
Kovid Goyal (kovid) wrote :

Hmm, I tried creating bookmarks in that book on my mac and they all
worked. The bookmarks you created somehow have no position information
in them. I will change calibre in the next release to at least show an
error when this happens rather than creating a non-functioning bookmark.
However, without a way to reproduce the creation of the non-functioning
bookmarks I cant actually fix the problem. Have you changed any viewer
settings from defaults?

Changed in calibre:
status: New → Invalid
Revision history for this message
Chris Lott (fncll) wrote :

The only preference in the entire preferences area was adding a toolbar, but I reset the defaults for everything, restarted, and same problem with the file I shared. Is there anyplace I can look for the error, in a log or something? Or will that be something to wait for the next release to see more information about?

Revision history for this message
Chris Lott (fncll) wrote :

Note: I found how to run the Viewer in debug mode, and noted this error for a bookmark that couldn't be found:

Failed to parse CFI: 'epubcfi(/472/2/4/2/6@49.10:58.26)'

Weirdly, though, bookmarks added in debug mode worked! And now when I launch the book viewer normally, they are still working. So I guess this is resolved, though I'm not sure how.

I will re-open, or re-file, if the problem reoccurs.

Revision history for this message
Kovid Goyal (kovid) wrote :

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.