Tag manager won´t open

Bug #2018598 reported by Alvaro Hernandez
This bug affects 1 person
Affects Status Importance Assigned to Milestone

Bug Description

I have a Calibre database on my google drive (cloud) which I access from multiple machines (never simultaneously).

It always (for years) worked just fine.

Today, I tried to open the tag manager (right-clicking on tag and selecting tag manager) in one of my machines and I got the following error:

calibre, version 6.17.0
ERROR: Unhandled exception: <b>TypeError</b>:'NoneType' object is not iterable

calibre 6.17 embedded-python: True
Windows-10-10.0.19045-SP0 Windows ('64bit', 'WindowsPE')
('Windows', '10', '10.0.19045')
Python 3.10.1
Windows: ('10', '10.0.19045', 'SP0', 'Multiprocessor Free')
Interface language: None
Traceback (most recent call last):
  File "calibre\gui2\tag_browser\ui.py", line 284, in do_tags_list_edit
  File "calibre\gui2\dialogs\tag_list_editor.py", line 230, in __init__
  File "calibre\gui2\dialogs\tag_list_editor.py", line 425, in fill_in_table
  File "calibre\gui2\dialogs\tag_list_editor.py", line 390, in create_table
TypeError: 'NoneType' object is not iterable

Tag manager is running smoothly on another machine.

I already tried uninstalling and reinstalling to no avail.

Please advise.


To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.