edit metadata, comments duplicating

Bug #1949167 reported by Armin Geller
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Unassigned

Bug Description

Hello Kovid,
there is a little problem in calibre 5.31 with edit metadata. Comments are duplicating multiple when removing formatting.

How to replicate:
1. Copy a text from an webpage into comments with paste and match style
2. Mark all text with select all
3. Delete formatting with remove formatting

calibre 64bit version 5.31
OS: windows 10 64bit

Best regards,
Armin

Revision history for this message
Armin Geller (armingeller) wrote :
description: updated
Revision history for this message
Kovid Goyal (kovid) wrote :

This is caused by https://bugs.launchpad.net/lxml/+bug/1928795

I will release 5.31.1 with a fix soon.

Changed in calibre:
status: New → Fix Released
Revision history for this message
Armin Geller (armingeller) wrote :

This have fix the problem.
Thanks a lot and best regards,
Armin

Revision history for this message
Gerd Wassermann (neptun-55) wrote : AW: [Bug 1949167] Re: edit metadata, comments duplicating

Do you have any expectation when a corrected version will be available?

-----Ursprüngliche Nachricht-----
Von: <email address hidden> [mailto:<email address hidden>] Im Auftrag von Armin Geller
Gesendet: Freitag, 29. Oktober 2021 12:28
An: <email address hidden>
Betreff: [Bug 1949167] Re: edit metadata, comments duplicating

This have fix the problem.
Thanks a lot and best regards,
Armin

--
You received this bug notification because you are subscribed to a duplicate bug report (1949176).
https://bugs.launchpad.net/bugs/1949167

Title:
  edit metadata, comments duplicating

Status in calibre:
  Fix Released

Bug description:
  Hello Kovid,
  there is a little problem in calibre 5.31 with edit metadata. Comments are duplicating multiple when removing formatting.

  How to replicate:
  1. Copy a text from an webpage into comments with paste and match style
  2. Mark all text with select all
  3. Delete formatting with remove formatting

  calibre 64bit version 5.31
  OS: windows 10 64bit

  Best regards,
  Armin

To manage notifications about this bug go to:
https://bugs.launchpad.net/calibre/+bug/1949167/+subscriptions

Revision history for this message
Kovid Goyal (kovid) wrote :

its already available.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers