Metadata wrong for auto-added books

Bug #1945889 reported by Florian Bach
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Unassigned

Bug Description

I've written a Calibre FileTypePlugin which automatically turns Adobe ACSM files into EPUB or PDF files upon import: https://www.mobileread.com/forums/showthread.php?t=341975

When using this plugin by dragging-and-dropping an ACSM file into the Calibre window, it's working as intended. Same for when I click "Add Books" and then select the ACSM file - works great, too.

But when I set up the Calibre Auto-Add thing (where it monitors a folder) and click "Add all file types" (because Calibre doesn't know that ACSM files are books), then it *does* add the Book, my plugin does run and turns the file into a valid EPUB or PDF, but the resulting book metadata (Title, Author, Cover, ...) is still taken from the ACSM file (so, default cover, author "Unknown" and Title being the file name) and not from the EPUB or PDF which the FileTypePlugin outputs.

So it looks like with the "manual" import Calibre reads the metadata after all FileTypePlugins are done (as it should), but with automatic import it reads the metadata immediately before the plugins run.

Could this be fixed so that auto-added ACSM files will have correct metadata in Calibre? Or is there some function I could call after the EPUB/PDF is ready to make it read the metadata from the file again?

I am running Calibre 5.28 on Linux.

description: updated
description: updated
description: updated
Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers