Html conversion BookTitle

Bug #1936792 reported by René Bogaers
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Unassigned

Bug Description

Interpretation of the HTML id BookTitle seems caps sensitive, if you try to convert an HTML with id BookTitle, it fails, bookTitle (notice the small 'b" vs captial 'B') works OK
Calibre version 5.23

Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1936792

I dont follow, what is failing? And note that ids in HTML are case
sensitive as per the HTML specification.

 status invalid

Kovid Goyal (kovid)
Changed in calibre:
status: New → Invalid
Revision history for this message
René Bogaers (rbogaers) wrote : RE: [Bug 1936792] Re: Html conversion BookTitle

If you try to convert an html file with tag "BookTitle"  in it, the conversion fails. If you then change it to "bookTitle" the conversion is OkRené
-------- Oorspronkelijk bericht --------Van: Kovid Goyal <email address hidden> Datum: 19-07-21 13:45 (GMT+01:00) Aan: <email address hidden> Onderwerp: [Bug 1936792] Re: Html conversion BookTitle ** Changed in: calibre       Status: New => Invalid-- You received this bug notification because you are subscribed to the bugreport.https://bugs.launchpad.net/bugs/1936792Title:  Html conversion BookTitleStatus in calibre:  InvalidBug description:  Interpretation of the HTML id BookTitle seems caps sensitive, if you try to convert an HTML with id BookTitle, it fails, bookTitle (notice the small 'b" vs captial 'B') works OK  Calibre version 5.23To manage notifications about this bug go to:https://bugs.launchpad.net/calibre/+bug/1936792/+subscriptions

Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1936792

Attach an HTML file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny yellow icon next to "This report contains Public information" in the top right area of the bug's page.

 status incomplete

Changed in calibre:
status: Invalid → Incomplete
Revision history for this message
René Bogaers (rbogaers) wrote :

see attached example rar file with two HTML files, if you try to convert these (to eg EPUB), one fails (A War of Gifts.html) and one succeeds (A War of Gifts OK.html)
according to me the official tag for HTML is 'BookTitle'
I also include the failure report from Calibre (errorlog.txt)
Hope this clear things a bit, it's not a problemic bug, as I can easily circumvent it, but the errorlog is very vague and it took me a while to identify which tag was actually failing

Revision history for this message
René Bogaers (rbogaers) wrote : Re: [Bug 1936792] Re: calibre bug 1936792

Done.

Op ma 19 jul. 2021 om 16:40 schreef Kovid Goyal <<email address hidden>
>:

> Attach an HTML file demonstrating/reproducing the problem to this bug
> report. You can do that by clicking the "Add attachment or patch" link
> at the bottom of the bug's page. If the file you are attaching is
> copyrighted, mark the bug as private. You can do this by clicking the
> tiny yellow icon next to "This report contains Public information" in
> the top right area of the bug's page.
>
> status incomplete
>
> ** Changed in: calibre
> Status: Invalid => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1936792
>
> Title:
> Html conversion BookTitle
>
> Status in calibre:
> Incomplete
>
> Bug description:
> Interpretation of the HTML id BookTitle seems caps sensitive, if you try
> to convert an HTML with id BookTitle, it fails, bookTitle (notice the small
> 'b" vs captial 'B') works OK
> Calibre version 5.23
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/calibre/+bug/1936792/+subscriptions
>
>

Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
Revision history for this message
René Bogaers (rbogaers) wrote : RE: [Bug 1936792] Fixed in master

That was quick😂 thanks!
-------- Oorspronkelijk bericht --------Van: Kovid Goyal <email address hidden> Datum: 19-07-21 17:55 (GMT+01:00) Aan: <email address hidden> Onderwerp: [Bug 1936792] Fixed in master Fixed in branch master. The fix will be in the next release. calibre isusually released every alternate Friday. status fixreleased** Changed in: calibre       Status: Incomplete => Fix Released-- You received this bug notification because you are subscribed to the bugreport.https://bugs.launchpad.net/bugs/1936792Title:  Html conversion BookTitleStatus in calibre:  Fix ReleasedBug description:  Interpretation of the HTML id BookTitle seems caps sensitive, if you try to convert an HTML with id BookTitle, it fails, bookTitle (notice the small 'b" vs captial 'B') works OK  Calibre version 5.23To manage notifications about this bug go to:https://bugs.launchpad.net/calibre/+bug/1936792/+subscriptions

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments