OPDS 'up' navigation issue

Bug #1932992 reported by Sherman Perry
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Unassigned

Bug Description

I'm currently developing an OPDS client, and during testing, I've noticed an issue with Calibre supplying broken 'up' catalog links.

Testing on Windows 10 64-bit, with Calibre 5.21 64 bit.

The problem can be reproduced manually in Chrome:
1. Navigate to <server>:<port>/opds
2. Navigate to the 'href' path for 'By Authors' (paste into URL bar)
3. Navigate to the 'href' path for 'calibre:category-group:authors:A' (or other)
4. Navigate to the 'href' path for '<link type="application/atom+xml;type=feed;profile=opds-catalog" rel="up"'
5. Calibre replies with a 404 and the error 'Category 'A' not found'

Please let me know if you need any more information. Or if I've got things completely wrong and this is not a bug...

Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
Revision history for this message
Sherman Perry (shermp) wrote :

Thanks Kovid. Much appreciated.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers