E-book viewer: the list of keyboard shortcuts should be displayed just below the action button

Bug #1924853 reported by etc205
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Unassigned

Bug Description

1. Open a book in the viewer.
2. Right-click to open Controls and click on "Preferences -> Keyboard shortcuts".
3. Click on the very first action button, "Auto scroll faster".

Seems like nothing happens, however the list of keyboard shortcuts for "Auto scroll faster" (consisting of one item, "Alt+ArrowUp") does open. The problem is it opens at the bottom of the actions list and to change it you have to scroll all the way down. This isn't very convenient, so perhaps it should be opened immediately below the "Auto scroll faster" button.

Calibre version: 5.16,
OS: Windows 10 Home 1803.

Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers