Quickview: Slight lag when viewing composite column in quickview

Bug #1920733 reported by ownedbycats
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Charles Haley

Bug Description

Calibre 5.13 (x64)

Steps to replicate:

1. Have a composite column that works selectable in quickview. I tested with a taglike.
2. Open quickview.
3. Select the composite column.
4. Use arrow keys to navigate the book list.

On my library of about 5000 books, there is a slight delay when navigating the book list. This delay is not present when a non-composite column is selected or if quickview is closed. I suspect quickview might be recalculating the values before displaying them.

Thank you!

EDIT: Correction: Originally I stated I tested with a not-taglike too but I was unable to replicate that second time as it didn't appear in the quickview again.

description: updated
Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1920733

Changing the component for this bug.

 assignee cbhaley
 status triaged

Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
description: updated
description: updated
description: updated
Revision history for this message
Charles Haley (cbhaley) wrote :

This problem is not directly related to composite columns but is instead related to the total number of items in the quickview pane. For example, it is repeatable using Languages.

Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers