back keyboard shortcut not working [solved]

Bug #1918105 reported by Duns
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Fix Released
Undecided
Unassigned

Bug Description

I noticed that, in paged mode, I can't go back (just) one page, but only two or more page (before), either with page-up key, or left-arrow or previous-page icon.
Right-arrow (and next page icon) is ok, it works like the page-down key, as expected.

Linux KDE Neon, with the latest Calibre release, Italian keyboard (but the problem is the mouse as well, so I don't think the problem is keyboard)

Duns (jduns)
description: updated
Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1918105

Works for me. Make sure you have the arrow keys bound to the "Scroll
right" and "Scroll left" action in the viewer preferences.

 status invalid

Changed in calibre:
status: New → Invalid
Revision history for this message
Kovid Goyal (kovid) wrote :

As for mouse scrolling its behavior is controlled in the scrolling
behavior section of the viewer preferences.

Revision history for this message
Duns (jduns) wrote : Re: back keyboard shortcut not working

Sorry, but I can't solve: when I press back, I go two pages before, even with the icon (previous page).

Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1918105

That is what the page turn buttons are supposed to do. If you want to
turn a single column use the arrow keys or configure the mouse
accordingly.

Revision history for this message
Duns (jduns) wrote : Re: back keyboard shortcut not working

I see. How should I do?

Revision history for this message
Duns (jduns) wrote :

If I use left-arrow only to "scroll left", I go always left *two* pages, and not only one.

Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1918105

I cannot reproduce that, sorry.

Revision history for this message
Duns (jduns) wrote : Re: back keyboard shortcut not working

This is a strange behavior I noticed in at least three different PC with KDE Neon (and different keyboard/mouse hardware).
Furthermore, to be honest I don't understand why the default behavior of a back command should be (unlike the forward one) go back *two* pages instead of one.
So the only way to go back one page is 1) to go back two pages, and 2) then go forward one: a bit complicated, I think...

Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1918105

The default action of the left arrow key goes back one column at a time,
not two.

Revision history for this message
Duns (jduns) wrote : Re: back keyboard shortcut not working

Not on my (three different) KDE Neon PC, though.
Couldn't you yourself try with a KDE Neon (virtualbox) installation?
I think that 1) if you can say what I should do to get a correct behavior this is not a bug, but 2) if you can't say that, this is a bug.
Calibre is an excellent program, and I thank you for your precious work and I appreciate very much the new interesting improvements you made. But if I can't easily go back one column a time, this in my opinion is a problem. To solve. Without hurrying, of course.
Thank you!

Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1918105

Works fine for me on KDE as well. I dont see what earthly difference the
desktop environment would make. Simply make sure the left arrow key is
set to the scroll left action in the viewer keyboard shortcuts
preferences.

Revision history for this message
Duns (jduns) wrote : Re: back keyboard shortcut not working

You can see yourself: even after restoring shortcuts to default, with the icons, go forward works correctly, but go back doesn't work as expected (it go two pages before).
And arrow-left, even after restoring shortcuts to default, go *two* pages before (I cannot record my hands, but I say the truth).
Maybe is a problem of Italian keyboard?

Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1918105

We appear to be talking at cross purposes. I am talking about when you
display two page at once in the viewer. You appear to be talking about
scrolling behavior with a single page displayed. And looking at your
viewer it looks like you have customized a wholebunch of thigs, this
isprobably caused by that. Restore everything to defaults (delete
viewer-webengine.json in the calibre config directory) and then see if
you can figure out what is causing it, by restoring your settings one by
one.

Revision history for this message
Duns (jduns) wrote : Re: back keyboard shortcut not working

Excellent! Following you instructions, I found where was the problem: in left and right margin 0 in page payout.
Setting left and right margins as 1 has solved the problem!
Thank you very much!

summary: - back keyboard shortcut not working
+ back keyboard shortcut not working [solved]
Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers