Edit Metadata: Non-default layout and custom longtext column breaks formatting shortcuts

Bug #1905479 reported by ownedbycats
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre 5.5 x64, Windows 10 Home (2004).

When using either "Compact Metadata" or "All-on-1-tab" layout and there is at least one custom longtext column, formatting shortcuts (Ctrl+B, Ctrl+I, Ctrl+U) fail in any WYSIWYG longtext columns (including the default 'Comments').

It works as expected when the layout is set to Default or if there is no custom longtext column.

Discovered in my main Calibre (it's been present for at least a year; prior to today I thought the lack of formatting shortcuts was by design) but the testing was done in a clean-config portable version.

Thank you.

description: updated
description: updated
description: updated
summary: - Edit Metadata: Non-default layout breaks formatting shortcuts
+ Edit Metadata: Non-default layout and custom longtext column breaks
+ formatting shortcuts
description: updated
description: updated
Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
Revision history for this message
ownedbycats (ownedbycats) wrote :

This bug appears to be recurring again in 5.29.

Thank you.

Changed in calibre:
status: Fix Released → Incomplete
status: Incomplete → Confirmed
Revision history for this message
Kovid Goyal (kovid) wrote :

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers