Renaming saved search from tag browser crashes Calibre

Bug #1901273 reported by ownedbycats
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Charles Haley

Bug Description

Calibre 5.3 (beta), Windows 10 Home 2004.

Steps to replicate:

1. Have a saved search "Recently Updated Fanfics."
2. Right-click it in the tag browser and click Rename.
3. Type in "Recently Updated Fanfiction" and press enter.

I got an error telling me that "Recently Updated Fanfics" (the original name) was already in use. Then Calibre crashed.

Renaming saved searches from the Manage Saved Searches dialog works as intended.

description: updated
description: updated
Revision history for this message
ownedbycats (ownedbycats) wrote :

I ran in debug mode, but it didn't log anything past the initial startup.

Charles Haley (cbhaley)
Changed in calibre:
assignee: nobody → Charles Haley (cbhaley)
status: New → Triaged
Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers