Doesn't launch on UBUNTU 20.04.1 LTS

Bug #1899674 reported by Pascal MICHEL on 2020-10-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre was running until the last update. I don't know how to find the content of the last update.

I uninstalled and installed. Still doesn't launch.

--version (calibre 4.99.4)

This the trace I have when I run calibre in Terminal.

Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 543, in main
    listener = create_listener()
  File "/usr/lib/calibre/calibre/gui2/main.py", line 514, in create_listener
    return Listener(address=gui_socket_address())
  File "/usr/lib/calibre/calibre/utils/ipc/server.py", line 110, in __init__
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'

Eli Schwartz (eschwartz) wrote :

Distro packages are not supported here. Distro packages are supported by your distro.

If you cannot reproduce your problem with https://calibre-ebook.com/download_linux then it's not a bug in calibre and you need to ask your distro to fix their intersection of

calibre source code version
python version
qt5 version
various other python module dependencies, or versions thereof

Specifically, the error traceback you reported has been reported several times here, and continues to be not a bug. You're using the 4.99.x unsupported beta version packaged by debian and derivatives (no longer available in Debian, but apparently Ubuntu never got the memo).

tl;dr update to calibre 5.0 or greater, your problems will disappear. Or tell your distro if they really want to package broken betas, they need to sync updated versions of those broken betas from Debian, and do so *promptly*.

Changed in calibre:
status: New → Invalid
Eli Schwartz (eschwartz) on 2020-10-13
tags: added: not-our-bug ubuntu-bug
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers