Calibre crashes immediately upon start

Bug #1899029 reported by Biep on 2020-10-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Here is what happens:
biep@blok:~$ calibre
Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 543, in main
    listener = create_listener()
  File "/usr/lib/calibre/calibre/gui2/main.py", line 514, in create_listener
    return Listener(address=gui_socket_address())
  File "/usr/lib/calibre/calibre/utils/ipc/server.py", line 110, in __init__
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'

I do not provide support for people using distro provided packages. If you are using a distro provided package, uninstall it and install the official calibre binary from https://calibre-ebook.com/download_linux and if you can reproduce the bug with that, re-open the ticket. Of course, if you are already using the official binary, apologies and feel free to re-open the ticket immediately :)

 status invalid

Changed in calibre:
status: New → Invalid
Biep (biep) wrote :

Thanks for your quick answer. When I have a good Internet connection again I'll try the direct package. Is there a PPA for that, so that it will update "automatically"?

Biep (biep) wrote :

(It may take a while before I have enough Internet for that..)
A PPA would be very helpful - and as you are on Launchpad, it would seem easy to add too.

Eli Schwartz (eschwartz) wrote :

https://manual.calibre-ebook.com/faq.html#why-doesn-t-calibre-have-an-automatic-update

Note the last bullet point. I wrote the third-party updater for linux. A lot of people have been pretty happy with it over the years.

Biep (biep) wrote :

Installed, and it works. Now I hope the distro version will update soon, because I like being able to update everything with one single command.
BTW, wouldn't a PPA be from Launchpad - so downloads wouldn't eat from your bandwidth? That might help a lot in reducing network usage.

Kovid Goyal (kovid) wrote :

Linux is less than 5% of calibre users, its bandwidth costs are
inconsequential.

Biep (biep) wrote :

I saw that we now have a dark mode, and
  env CALIBRE_USE_DARK_PALETTE=1 calibre --detach
indeed works - but not in .desktop files, where it still will open calibre in light mode. Any ideas?

Kovid Goyal (kovid) wrote :

Set the environment variable ssytem wide or in the .desktop file itself

Biep (biep) wrote :

I wasn't clear.
Setting the line given in the .desktop file does not turn the dark palette on.
  Exec=env CALIBRE_USE_DARK_PALETTE=1 calibre --detach %F
starts a white palette calibre.
Yes, I can set it globally as a workaround - I was just reporting a bug.

If you have a new bug to report, please open a new ticket.

On the topic of a PPA, I don't think it's Kovid's responsibility to
learn how distro packaging works, in this case Debian/Ubuntu packaging.

You're vastly oversimplifying things.
It's *not* easy. Debian packaging is optimized to make it easy for
debian maintainers to maintain tens of thousands of packages, but in a
way that makes it extremely hard to learn how to do it unless you're
already an expert.

Furthermore, why Debian/Ubuntu specifically? Maybe he should provide
packages for a dozen other distros too? Figure out exactly what's wrong
with the distro package, solve it, and instead of getting the distro to
fix things, provide alternative builds?

Who is going to test the system library integrations?

Why can't you just ask the Ubuntu maintainers to "provide a working PPA"
except they could even do it in their official repos?

No. This is not the job of software developers. In fact, let me put on
my distro developer hat for a moment, and state for the record:

It is better for:
- distros
- users
- software developers

if the software developer focuses on his are of expertise, writing the
software, and distros focus on their area of expertise, distributing the
software.

http://kmkeen.com/maintainers-matter/

...

Addendum: In some cases, software developers provide one universal
binary that works everywhere, but doesn't integrate with the distro.
This is great: users can update ahead of their distro and get something
generally guaranteed to work, but the software developer doesn't need to
spend *all his time* fighting with distribution. Instead, he could add
features to the program.

calibre does this. Be happy you have what you have.

Instead of asking for Kovid to provide you with PPAs, I encourage you to
submit a bug report to your distro.

That's not how you set env vars in desktop files, there is a dedicated
key for it, a bit of googling will show you how.

Biep (biep) wrote :

Actually, this was what Googling told me to do - for example in https://askubuntu.com/questions/144968/set-variable-in-desktop-file .
And there doesn't seem to be a dedicated key for it: https://specifications.freedesktop.org/desktop-entry-spec/desktop-entry-spec-latest.html#recognized-keys

I am not saying the bug is at your side - it might be in Ubuntu -, but there definitely seems to be a bug.

Biep (biep) wrote :

> On the topic of a PPA, I don't think it's Kovid's responsibility to learn how distro packaging works, in this case Debian/Ubuntu packaging.

It isn't, obviously. I merely read a complaint about huge amounts of bandwidth, and tried to be helpful. The same is true regarding the environment variable bug - I have a workaround that works well, and *for myself* have no issues at all. I am merely trying to look beyond my own needs.

It seems you're using an old, unsupported beta: debian found and fixed
this here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=959559

Ubuntu might not have synced this fixed version. But they really should
update to 5.x instead of the never-released 4.99.x betas.

Eli Schwartz (eschwartz) on 2020-10-13
tags: added: not-our-bug ubuntu-bug
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.