Conversion from epub to mobi en v5.2

Bug #1898894 reported by Odinokij Volk
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Attached book (i have found several books with this problem) is converted from epub to mobi ok in calibre v4.23 but in version 5.2 the resulting mobi book jumps from cover to end in the ebook-viewer, despite the mobi file size looks right.

Note: I've made more tests in Calibre v5.2 for Windows. If I convert the book from epub to mobi, and then click the "MOBI" link of Formats in the book description, after "preparing book for first reading, wait..." the book in mobi format cannot be read (it jumps from cover to end). But... if I convert it from epub to mobi and then I press key "O" to open the folder and double click to mobi book, after "preparing... wait" it opens correctly and later I can also open it from calibre without problem. So I think the problem is in the "preparing book for first reading" when doing it from inside calibre, in v5.2.

Revision history for this message
Odinokij Volk (odinokijvolk) wrote :
description: updated
description: updated
Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
Revision history for this message
Odinokij Volk (odinokijvolk) wrote :

Thank you, Kovid

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers