Menu items on the Convert Books Box are slow to respond

Bug #1898221 reported by David Yearsley
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Since the upgrade to 5.0 when clicking the Convert Books button, it is slow to respond. Once the window opens all of the menu items in the window are very slow to respond.This only occurs when you are converting just 1 book. If you have more than one book selected everything responds very fast.

Attaching a screen shot of the window involved.

Revision history for this message
David Yearsley (dlyearsley-msn) wrote :
Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1898221

Works fine for me. I am guessing you are on windows? If so, try
rebooting in safe mode and see if the problem goes away. Most likely it
is something interfering with calibre.

 status invalid

Changed in calibre:
status: New → Invalid
Revision history for this message
David Yearsley (dlyearsley-msn) wrote :

I am having the same issue on 2 other window machines not just my main one. (3 total) It appears there is something in the loading process that is hanging. I have seen it when I am programming. It is usually a loop or something that should not be there or a module that is slow to load. It has only started happening since I upgrade to 5 on the three machines.

I upgraded one of my Ubuntu machine and tested there and it does not appear to have the same issue.

I am not talking a major slowdown.

If I am converting just 1 book the convert window takes 4 to 5 seconds to open. When I click on Structure detection it takes 6 to 7 seconds. Once I click Structure detection then all of the other menu items work very quickly. Usually about 1 second, until I click Metadata and then the slowness starts over again. Clicking on metadata always takes 4 to 5 seconds to respond.

If I have 2 or more books selected to convert the convert window takes less than a second to open. All of the menu items respond in less that a second. I also noticed that the Metadata is removed from the list. I suspect that the Metadata module load is the cause of this slowdown.

Revision history for this message
Kovid Goyal (kovid) wrote :

I asked you to try rebooting in safe mode. Instead of assuming I dont know what I am talking about, why dont you try that.

Revision history for this message
David Yearsley (dlyearsley-msn) wrote :

Sorry I forgot to mention that was the first thing I tried, but had the same response. Once I had confirmed there was no improvement in Debug mode I started to look for other reasons as to why it would work fine when converted two or more books.

That is when I found the issue with the metadata link on the list on the left.

Revision history for this message
David Yearsley (dlyearsley-msn) wrote :

I also noticed that when the conversion box opens up the default for the list is meta data which is the selection that seems to slow everything down.

I should apologize for not mentioning in the first message that the first thing I did was to try your suggestion. As a programmer I should have remembered it is important to include all information.

Revision history for this message
David Yearsley (dlyearsley-msn) wrote :

As an added check I tried debug mode on a second computer just now with the same results. There is no improvement in performance. The minute you select Meta data on the menu it takes 5-7 seconds to load the screen.

Revision history for this message
David Yearsley (dlyearsley-msn) wrote :

Something else I have discovered: When you open Convert books window and click on Output Format it takes between 10 and 15 seconds to select an Output.

If you select a different item off the left menu, anything but Metadata and then click on Output Format it is almost instant.

Revision history for this message
Kovid Goyal (kovid) wrote :

Not sure what you mean by "debug" mode, I mean windows safe mode, https://support.microsoft.com/en-in/help/12376/windows-10-start-your-pc-in-safe-mode

Revision history for this message
David Yearsley (dlyearsley-msn) wrote :

I have not been able to get my computer into safe mode. I cannot get past the password. I have not used it in a long time and all of the passwords I tried did not work. I have been using the Microsoft code. I am still working on trying to get into safe mode.

I did want to explain why I feel this is part of the 5 upgrade. On the Thursday before the upgrade my 4.xx version worked just fine. The next day when I upgraded to 5.01 I noticed the performance issue. I figured I would wait until the next upgrade to see if it was fixed. This has worked for several issues in the past. When the next upgrade did not fix the issue was when I submitted the issue.

Where the only change on my computer from Thursday to Friday was the upgrade to 5.01 I would be very surprised if this was an issue with my computer.

I will let you know when I can get one of my Windows machines into safe mode.

Revision history for this message
Kovid Goyal (kovid) wrote :

feel free to downgrade to 4.23 if you like, old version of calibre are
linked to from the windows download page.

Revision history for this message
David Yearsley (dlyearsley-msn) wrote :

Is there any way to change the menus on the Convert Books. I would like to remove the Metadata button as it is the button causing the slow down?

Revision history for this message
Kovid Goyal (kovid) wrote :

No.

Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers