Weird dbus error with the systray menu on Linux

Bug #1897571 reported by NiLuJe
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Calibre 5.0.1, on Linux x86_64 (Gentoo), on Plasma 5/X11.

I'm getting a weird dbus error when attempting to show the systray menu (the icon itself is fine), which prevents said menu from actually showing up.
Full debug log attached (ignore the not-yet-updated plugins, and basically jump to the end. The message shows up on startup, and is repeated each time one attempts to open the systray menu).

I initially thought it was a weird build issue with my source builds, but it turns out I can reproduce it with the official binary releases, hence this report ;).

Revision history for this message
NiLuJe (niluje) wrote :
Revision history for this message
Kovid Goyal (kovid) wrote : Re: calibre bug 1897571

Probably something in the dbus binding for the menu broke with python 3,
will look into it when I have a moment.

Revision history for this message
Kovid Goyal (kovid) wrote :

Relevant code is in dbus_export/menu.py if you wish to investigate.

Revision history for this message
NiLuJe (niluje) wrote :

I have a rather strong allergy to anything dbus-related (^^), but I'll see if anything jumps out at a quick glance, thanks ;).

Revision history for this message
Kovid Goyal (kovid) wrote : Fixed in master

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
Revision history for this message
NiLuJe (niluje) wrote :

That did the trick, thanks ;).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments