Calibre 4.21 editor hangs (randomly?) in Windows 10

Bug #1889047 reported by Xopa on 2020-07-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Don't know if this is due to editing a large book (205.4mb)
Reverted to 4.20 and does not hang.
Can minimize ,restore and maximize but not close.
Must use task manager to end process.

Xopa (xopa) wrote :

this is on the 64bit version

Attach an ebook file demonstrating/reproducing the problem to this bug report. You can do that by clicking the "Add attachment or patch" link at the bottom of the bug's page. If the file you are attaching is copyrighted, mark the bug as private. You can do this by clicking the tiny yellow icon next to "This report contains Public information" in the top right area of the bug's page.

 status incomplete

Changed in calibre:
status: New → Incomplete
Xopa (xopa) wrote :
Xopa (xopa) wrote :
Kovid Goyal (kovid) wrote :

Works for me, steps I tried:

1) Open the attached file in the editor
2) Double click on ch-01-1.html
3) Move the cursor around and perform various minor edits in that file
4) No freeze

Is there some set of steps I can follow to reproduce?

Xopa (xopa) wrote :

I have a feeling that it might be too many processes running at once
- formatting file preview
- spell check (in editor)
- formatting (color) in editor
- search & replace (all files)
- ...

Try opening subj-index_03.html
then do an immediate global search & replace
then save.

(maybe my computer is to slow i7-2600 3.4GHz 3.7GHz 16GB RAM)

Xopa (xopa) wrote :

Note that when the editor hangs it still uses 6%-9% of CPU

Xopa (xopa) wrote :

 Have a feeling it is caused by the file preview
Changed
================================
 .hi p {
    margin-bottom: 0;
    margin-top: 0;
  }
  h6 {
    margin: 0;
  }
  body {
    page-break-before: avoid;
  }
  </style>
</head>

<body>

  <blockquote class="hi">
===================================
to
===================================
  .hi p {
    margin-bottom: 0;
    margin-top: 0;
  }
  body {
    page-break-before: avoid;
    margin-left:2em;
  }
  </style>
</head>

<body class="hi">
====================================
Possibly easier to format
Problem has not reoccurred (yet)

Xopa (xopa) wrote :

Sorry, hanging when I got further in the file
Due to impatience and not waiting for end of formatting. If I wait till all formatting is complete it does not seem to happen

Kovid Goyal (kovid) wrote :

Cant get it to hang for me, steps I tried:
1) Open subj-index_03.html
2) Perform some edits on the style for .hi p
3) Add class="hi" to body
4) No hangs though it takes a little while for highlighting to resync after editing the body tag

Xopa (xopa) wrote :

Try editing at the end of the file.
May have something to do with the CPU speed
Something has definitely changed between 4.20 & 4.21
Formatting seems to take a lot longer in 4.21 and at least on my computers (portable & desktop) it hangs
Have rolled back to 4.20 on both and problem disappeared on both machines.

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
Xopa (xopa) wrote :

Great. Thanks Heaps

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers