If I reduce font size below 10, then keyboard shortcut to increase font size stops working

Bug #1888609 reported by Gary on 2020-07-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

repro:

1. Use ctrl+minus or font size dialog to reduce font size until font size is very small (8 or 9 px).

2. Use ctrl+plus (or equals) to increase font size.

Expected: font size should increase.

Actual: font size does not change.

3. Use font size dialog to increase font size to 10 or higher.

4. Ctrl+plus works again.

This is in what, theviewer? What version of calibre? Whap operating
system? And I cannot reproduce this with current calibre release, steps
I tried:

1) Press ctrl+- multiple times till text size no longer reduces
2) Press ctrl++ text size increases, as expected

 status incomplete

Changed in calibre:
status: New → Incomplete
Gary (gmccullo) wrote :

Yes in the viewer.

calibre Debug log
calibre 4.21 [64bit] embedded-python: True is64bit: True
Windows-10-10.0.18362 Windows ('64bit', 'WindowsPE')
('Windows', '10', '10.0.18362')
Python 2.7.16+
Windows: ('10', '10.0.18362', '', u'Multiprocessor Free')
Interface language: None
Successfully initialized third party plugins: DeDRM (6, 6, 1) && EpubMerge (2, 9, 0)
calibre 4.21 [64bit] embedded-python: True is64bit: True
Windows-10-10.0.18362 Windows ('64bit', 'WindowsPE')
('Windows', '10', '10.0.18362')
Python 2.7.16+
Windows: ('10', '10.0.18362', '', u'Multiprocessor Free')
Interface language: None
Successfully initialized third party plugins: DeDRM (6, 6, 1) && EpubMerge (2, 9, 0)
Turning on automatic hidpi scaling
devicePixelRatio: 1.0
logicalDpi: 96.0 x 96.0
physicalDpi: 101.6 x 101.6
Using calibre Qt style: True
[0.00] Starting up...
[0.00] Showing splash screen...
[0.72] splash screen shown
[0.72] Initializing db...
[0.75] db initialized
[0.75] Constructing main UI...
EpubMerge: DEBUG: 2020-07-24 07:36:39,780: calibre_plugins.epubmerge.epubmerge_plugin(157): macmenuhack file_path:C:\Users\gary\AppData\Roaming\calibre\plugins\fanficfare_macmenuhack.txt
[3.42] main UI initialized...
[3.42] Hiding splash screen
[21.24] splash screen hidden
[21.24] Started up in 21.24 seconds with 215 books

Gary (gmccullo) wrote :

FYI This morning I upgraded from the version I was on yesterday (4.20) to most recent release (4.21) as you can see above and retested. And I just now noticed that ctrl-+ doesn't work at all now, no matter what my current font size is. Ctrl-- still works though.

Kovid Goyal (kovid) wrote :

Works for me on my windows machine. I suggest you try changing the
shortcut for it in the viewer preferences.

 status invalid

Changed in calibre:
status: Incomplete → Invalid
Gary (gmccullo) wrote :

I tried several different short cuts. I also removed the existing short cuts. Nothing works.

Kovid Goyal (kovid) wrote :

Then I am out of ideas, sorry

Gary (gmccullo) wrote :

Is there a way to save/restore all my settings? Then I could reset to defaults and re-test.

Kovid Goyal (kovid) wrote :

Preferences->Miscellaneous->Open config directory. Just rename it to
something else and you will have a blank slate

Gary (gmccullo) wrote :

So when I do that the font-size keyboard shortcuts work. How can we track down where the conflict is?

Kovid Goyal (kovid) wrote :

Most of the viewer settings are stored in the file viewer-webengine.json
which is editable using notepad++ or another programmers editor. You can
try deleting settings from it to find the culprit. Or post it here and I
will see if I can re-create your issue with it.

Gary (gmccullo) wrote :
Download full text (3.4 KiB)

Here it is. I cut out stuff like "saved searches" and the MRU list.

{
  "local_storage": {
    "search-bar-history-search-in-book": [
    ]
  },
  "main_window_geometry": {
    "__class__": "bytearray",
    "__value__": "AdnQywADAAD////8/////AAAB4MAAAQdAAAAAAAAACQAAARCAAACvQAAAAACAAAAB4AAAAAAAAAAFwAAB38AAAQZ"
  },
  "main_window_state": {
    "__class__": "bytearray",
    "__value__": "AAAA/wAAAAH9AAAAAgAAAAAAAAFEAAAEA/wCAAAAAvsAAAAWAHMAZQBhAHIAYwBoAC0AZABvAGMAawEAAAAAAAAEAwAAAJMA////+wAAABAAdABvAGMALQBkAG8AYwBrAAAAAAAAAAQDAAAAhwD///8AAAABAAACWwAABAP8AgAAAAT7AAAAHgBoAGkAZwBoAGwAaQBnAGgAdABzAC0AZABvAGMAawAAAAAA/////wAAAMYA////+wAAABwAaQBuAHMAcABlAGMAdABvAHIALQBkAG8AYwBrAgAAB6oAAAA0AAAD8AAAAof7AAAAFgBsAG8AbwBrAHUAcAAtAGQAbwBjAGsAAAAAAP////8AAABgAP////sAAAAcAGIAbwBvAGsAbQBhAHIAawBzAC0AZABvAGMAawIAAAKIAAAAJgAAAQgAAAI6AAAGAgAABAMAAAAEAAAABAAAAAgAAAAI/AAAAAEAAAAAAAAAAQAAAB4AYQBjAHQAaQBvAG4AcwBfAHQAbwBvAGwAYgBhAHIDAAAAAP////8AAAAAAAAAAA=="
  },
  "old_prefs_migrated": true,
  "saved-search-settings": {
  },
  "session_data": {
    "base_font_size": 13,
    "book_scrollbar": false,
    "columns_per_screen": {
      "landscape": 5,
      "portrait": 2
    },
    "controls_help_shown_count": 2,
    "current_color_scheme": "white",
    "footer": {
      "left": "empty",
      "middle": "empty",
      "right": "progress"
    },
    "header": {
      "left": "title",
      "middle": "section",
      "right": "pos-chapter"
    },
    "hide_tooltips": null,
    "keyboard_shortcuts": {
      "decrease_number_of_columns": [
        {
          "altKey": false,
          "ctrlKey": true,
          "key": "[",
          "metaKey": false,
          "shiftKey": true
        }
      ],
      "increase_font_size": [
        {
          "altKey": false,
          "ctrlKey": true,
          "key": "=",
          "metaKey": false,
          "shiftKey": false
        }
      ],
      "increase_number_of_columns": [
        {
          "altKey": false,
          "ctrlKey": true,
          "key": "]",
          "metaKey": false,
          "shiftKey": true
        }
      ]
    },
    "left-margin": {
      "left": "empty",
      "middle": "empty",
      "right": "empty"
    },
    "margin_bottom": 5,
    "margin_left": 5,
    "margin_right": 5,
    "margin_top": 25,
    "read_mode": "paged",
    "right-margin": {
      "left": "empty",
      "middle": "empty",
      "right": "empty"
    },
    "standalone_font_settings": {
      "minimum_font_size": 0,
      "serif_family": "Georgia",
      "zoom_step_size": 5
    },
    "standalone_misc_settings": {
      "remember_window_geometry": true,
      "save_annotations_in_ebook": false,
      "show_actions_toolbar": true,
      "show_actions_toolbar_in_fullscreen": true
    },
    "standalone_recently_opened": [],
    "user_color_schemes": {
      "*gary": {
        "background": "#f1d6c0",
        "foreground": "#000000",
        "name": "gary"
      }
    },
    "user_stylesheet": "body.calibre-viewer-paginated {\n column-gap: 1rem;\n column-rule: thin solid gainsboro !important;\n}\np {\n /*text-align: justify;*/\n text-justify: inter-word;\n line-height:...

Read more...

Kovid Goyal (kovid) wrote :

Your problem is most likely zoom_step_size. Remove that line and you
should be fine.

Gary (gmccullo) wrote :

Confirmed. But I like that setting. 20% is too much. :(

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Invalid → Fix Released
Gary (gmccullo) wrote :

Outstanding!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers