[Enhancement] Fuzzy search mode should ignore soft hyphens

Bug #1878046 reported by Alexander on 2020-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

Hi team,
I made use of the "Hyphenate This!" plugin found in the Calibre 4.15 (Windows) plugin selection.
This plugin correctly inserted the soft hyphens, using the character U+00AD (HTML: &shy), as exemplified in this example sentence: (There is a soft hyphen located after the first 2 letters of "instant")
"It happened in an in­stant."

Now the issue is, that the soft hyphens are not explicitly ignored by the search box within the editor as well as the epub viewer, making it impossible to search any words containing this special character, unless manually inserted. This means, that if a book contains the previous sentence as an example, the search box will not be able to find "It happened in an instant." (Now without the soft hyphen)
I believe that it should be possible to ignore that soft hyphen character, since it is already invisible.

The solution I would recommend is to expand the existing "fuzzy" search mode in the editor to ignore this character, and to add a fuzzy search option in the epub viewer which does the same. That is a recommendation, not an expectation, I look forward to whatever solution you may find.

Thank you for your time, cheers!

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers