calibre crashes on startup

Bug #1877180 reported by Jean-Noël AVILA on 2020-05-06
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

On Linux Debian testing, running calibre on command line yields this:
```
% calibre -v --ignore-plugins
Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 543, in main
    listener = create_listener()
  File "/usr/lib/calibre/calibre/gui2/main.py", line 514, in create_listener
    return Listener(address=gui_socket_address())
  File "/usr/lib/calibre/calibre/utils/ipc/server.py", line 110, in __init__
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'
```

Installed version:
```
% calibre --version
calibre (calibre 4.99.4)
% dpkg -l | grep calibre
ii calibre 4.99.4+dfsg+really4.12.0-1 all powerful and easy to use e-book manager
ii calibre-bin 4.99.4+dfsg+really4.12.0-1 amd64 powerful and easy to use e-book manager
```

Jean-Noël AVILA (jnavila) wrote :

commenting line 110 of /usr/lib/calibre/calibre/utils/ipc/server.py seems to make it go to the end.

This was already fixed in
https://github.com/kovidgoyal/calibre/commit/7b6416ac6522fc40f24f6baf3ca552b17a8b91d6

And released 5 days ago as v4.15.0

Please keep in mind https://www.debian.org/Bugs/Reporting as debian
recommends you *not* report bugs upstream for packages installed via
apt, but rather to report them to the debian bugtracker, where the
Debian package maintainer will check for updated versions that may fix
the bug, and potentially backport a bugfix.

 status fixreleased

Changed in calibre:
status: New → Fix Released
rubo77 (rubo77) wrote :

I have installed 4.99.4+dfsg+really4.12.0-1build1 on Ubuntu 20.04 and got the same error.

is there a workaround?

Graeme Gregory (graeme-gregory) wrote :

Work around in comment #1 works!

Eli Schwartz (eschwartz) wrote :

> I have installed 4.99.4+dfsg+really4.12.0-1build1 on Ubuntu 20.04 and
> got the same error.
>
> is there a workaround?

Please contact Ubuntu and request they upgrade to 5.0

Debian already did so a while ago. The unstable 4.99 betas never entered
a stable Debian release, and Debian bullseye was promptly upgraded as
the beta progressed, until finally reaching 5.0, but Ubuntu somehow
synced the wrong version and baked it into an LTS in a completely broken
state.

Haim Daniel (hdaniel) wrote :

To fix this on Ubuntu 20.04 , 4.99.4+dfsg+really4.12.0-1build1:

sudo sed -ie 's/self._listener._unlink.cancel/# self._listener._unlink.cancel'/ /usr/lib/calibre/calibre/utils/ipc/server.py

Carlos Pita (carlosjosepita) wrote :

Could this please be updated? Calibre is an important piece of software that is rendered useless by this bug, there has been a fix available for some months, a beta version was shipped in an LTS release, this surely justifies an exception.

Carlos Pita (carlosjosepita) wrote :

Besides, how can importance be undecided for a bug that makes a program unable to even start?

Eli Schwartz (eschwartz) wrote :

Clearly this won't be updated, because this is the calibre bugtrackers and not the Ubuntu bugtracker. On this bugtracker, the bug was tiny as it only affected a python3 build that was not enabled by default, and is anyways fixed. So no, it never "didn't start" in that sense.

On Ubuntu's bugtracker you may discuss *Ubuntu calibre*, a different product from *calibre*.

The former does not start. The latter starts.

Eli Schwartz (eschwartz) wrote :

Please see bug 1898904 for Ubuntu's tracking bug.

Carlos Pita (carlosjosepita) wrote :

Ah ok, thanks for clarifying that, I was assuming this was for the Ubuntu package since it's in Launchpad, never occurred to me that Calibre was indeed using Launchapd for its development, sorry.

Eli Schwartz (eschwartz) wrote :

No problem. :) You're not the first person to be similarly confused.

Launchpad is most popularly used by Ubuntu, but there are a number of other projects using it too, which tend to get lost in the shadow cast by Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers