After adjusting the auto scroll speed I am jumped back in the book

Bug #1863438 reported by Jonatan Nyberg on 2020-02-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
calibre
Undecided
Unassigned

Bug Description

After reading some time, I adjust the auto scroll speed (in Preferences -> Scrolling behavior) and I am for some reason always jumped back in the book.

description: updated
description: updated

Doesn't happen for me. I'm going to need some steps to reproduce. Steps
I tried:

1) Open book
2) Switch to flow mode
3) Start autoscroll
4) Open preferences and change autoscroll speed from 1 to 1.55
5) Close preferences
6) Wait 30 seconds. No jump back occurs

 status incomplete

Changed in calibre:
status: New → Incomplete
Jonatan Nyberg (jony0008) wrote :

Try browsing the book in Paged mode first and then switch to Flow mode, whenever I change the autoscroll speed I will be jumped back to where I was when I switched to Flow mode.

Try this steps:

1) Open book
2) Switch to Paged mode
2) Browse book to next chapter
3) Switch to Flow mode
4) Start autoscroll
5) Wait for a while for some page turns to occur
5) Open preferences and change autoscroll speed from 1 to 1.55
6) Close preferences
7) You are jumped back to where you switched to Flow mode in step 3)

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: Incomplete → Fix Released
Jonatan Nyberg (jony0008) wrote :

This is still not working correctly in calibre 4.11.1, now I am jumped to the beginning of the chapter.

Works for me.

Jonatan Nyberg (jony0008) wrote :

It works better now, because I am just jumped to the beginning of the current chapter and not to where I changed from Paged mode to Flow mode as before.

Please try:

1) Switch to Flow mode
2) Start autoscroll
3) Browse book to the middle or end of a chapter
4) Open preferences and change autoscroll speed
5) Close preferences
6) You are jumped to the beginning of the current chapter

Changed in calibre:
status: Fix Released → New

Fixed in branch master. The fix will be in the next release. calibre is usually released every alternate Friday.

 status fixreleased

Changed in calibre:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers